1

I have created an Approval Workflow (SharePoint 2010 Workflow) that submits an email to a manager to request approval. Works perfectly.

I don't want the user to be able to edit the list item after it has been submitted. So I inserted an Impersonation Step that changes the permission for the person who submitted it to Read.

After adding the Impersonation Step, the workflow "cancels".

How can I create the Approval Workflows that a user can submit and not edit the item and the workflow continues to the approval stage.

Thanks, Rob

3
  • Make sure you are granting the user account that the workflow is impersonating to still have full control of the item, otherwise your permission change may have just locked the workflow out.
    – willman
    Feb 20, 2020 at 1:34
  • Is this approval workflow on a List or Library?
    – willman
    Feb 20, 2020 at 1:34
  • Thank you! With the answers i have received i was able to walk thru my workflow and noticed that everything was good as suggested by others. The problem was that after my Impersonation step I update a field so that it's blank. I moved filed update to before the Impersonation. All is great now.. Thank you
    – Rob
    Feb 24, 2020 at 21:45

2 Answers 2

0

From your description "After adding the Impersonation Step, the workflow "cancels"."

What is your workflow steps?

What is the error message when the workflow is canceled?

To change the permission for the person who submitted the item to Read after the item has been submitte, create an 2010 platform workflow on the list and use "Replace List Item Permissions" action like the following:

enter image description here

Refer to the article about using a Workflow to remove or change item permissions:

https://www.c-sharpcorner.com/UploadFile/Roji.Joy/how-to-set-item-level-permission-using-sharepoint-designer-2/

1
  • Thank you! With the answers i have received i was able to walk thru my workflow and noticed that everything was good as suggested by others. The problem was that after my Impersonation step I update a field so that it's blank. I moved filed update to before the Impersonation. All is great now.. Thank you
    – Rob
    Feb 24, 2020 at 21:46
0

This can be achieved in two ways :

  • Using SharePoint designer workflow

  • Using customizing the list form in Infopath form

Using Designer Workflow approach :

Please follow the the below steps :

  • if you have a workflow associated to this list (or just create one!)

  • Edit the workflow

  • put your cursor above the first step in your workflow

  • from the ribbon, in the insert group choose "Impersonation step"

  • place your cursor in the Impersonation step and click

    on Actions from the ribbon

  • find and choose the "Replace List Item Permission" from the "List

    Actions" section

click on the "these permissions" and replace the permissions as you desire (read-only, etc)

  • click the "this list" and choose "Current Item"

  • save and publish your workflow

this way whenever the user submitted the list item and the workflow starts, it replaces their permissions they way you configured.

Using InfoPath form approach

Please follow the the below steps :

  • first, create a new field and call it for example "Redirect"

  • you have a default view for your form, where your users are filling

    the form through with full write permission

  • create a new view call it for example "Read-Only-View" (managed

    through Page Design> views)

  • "Ctrl+A" select everything on your default view and copy it

  • go to the newly created view, select all "Ctrl+A" > paste

  • right click a form field you wish would be read-only after form is

    submitted> click on properties > navigate display tab > tick

    the Read-Only check box.

  • repeat the above step for all fields required to be read only after

    submit.

  • create a action rule on your submit button> action> set a field's

    value. and choose the field "Redirect" you already created in the

    first step, and in the Value type "Yes"

  • create the following "Form load" action rule,  (click on data from

    the ribbon> Form Load):

    Condition: If Redirect field = "Yes"   >  choose the action "Switch

    View" and choose the view you created earlier "Read-Only-View"

  • save and publish your form.

now whenever the user submitted the form, the next time they open their entry, they'll have the read-only view.

Reference URL :

How to disable User EDIT list option after submitting entries 

1
  • Thank you! With the answers i have received i was able to walk thru my workflow and noticed that everything was good as suggested by others. The problem was that after my Impersonation step I update a field so that it's blank. I moved filed update to before the Impersonation. All is great now.. Thank you
    – Rob
    Feb 24, 2020 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.