i have Sharepoint 2016 integrated with RMS installed on server, i have some files on a sharepoint site for a department, whenever i try to access a word file on this site, i get the following error:

Sorry, we couldn't open 'http://.......doc'. ;

i have tried to upload a word file on this site and still can't open it, while i have tried to upload the same file to another site for another department, and this file opened normally.

what is the problem? is it something to do with the RMS?

Thanks in advance,

1 Answer 1


Try to follow the below work around for this issue :

  1. Move the documents to a new folder inside the document library from Site Settings-> Content and Structure

    That way they could be opened. But if I moved them back, they did not work again, like the link was broken.

  2. Temporarily left the files in the new folder

  3. Set the site and library to be reindexed with the next crawl.

  4. Ran full crawl overnight.
  5. Once the crawl was completed I moved the files back to the old location and cleared local office cache. Now both can be opened.

Similar thread is here :

Error when opening .docx file from SharePoint - "Sorry, we couldn't open (...)"

If above troubleshooting does not work, follow the below steps :

  1. Open MS Word
  2. Select "File" from the Ribbon
  3. Select "Account" from the left hand menu
  4. Select "Switch Accounts"
  5. Select "Add Account"
  6. Enter the User ID and Password for my Enterprise Account (SharePoint Online) and select the "Sign In" button.
  7. Once this was done, the Service connections to the sharepoint site were all re-connected and I dont have any issue opening office documents on the sharepoint site anymore.

Reference URL :

Sharepoint error "Sorry, we couldn't open 'http://site/file.xxx'"

  • i was able to view the documents after removing the irm from sharepoint admin center, so that the problem was in the irm, but now when i try to reenable irm, it gives the following error: The Required Active Directory Rights Management Service Client (MSIPC.DLL) Is Present But Could Not Be Configured Properly. IRM Will Not Work Until The Client Is Configured Properly
    – Ahmad
    Feb 10, 2020 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.