0

I am migrating from SharePoint 2016 to 2019.

My sites are doc libraries and I used Term Store Management to create my menus.

In 2016, my menus only show on top but now that I migrated, I can see the menus on top and on the left.

How do I hide the pane on the left?

Thanks

Christophe enter image description here

  • You should be able to hide the quick launch from Site settings > navigation or Site settings > Tree view. – Christoffer Feb 6 at 13:06
  • Going to Site settings > navigation brings me to the Term Set area. I don't see a quick launch option available with Term Set – MAS Services Feb 6 at 13:27
1

Option 1: Depending on the Site Template you used and features that are activated sometimes the "Navigation Elements" link is not visible on the "Site Settings" Page. But you can always navigate there manually. Add /_layouts/15/navoptions.aspx to the end of your site url, for example, https://yourtenantname.sharepoint.com/sites/yoursitename/_layouts/15/navoptions.aspx

You should see the following page with just two options:

Screenshot of NavOptions.aspx

Then just uncheck the "Enable Quick Launch" checkbox and click "OK".

Option 2: Go to the All Site Settings page, and under the "Look and Feel" section, choose the option titled "Change the look" -- this will take you to the "_layouts/15/designgallery.aspx" page. If you do not actually want to change your colors, choose the first option titled "Current". This brings up another page (see screenshot below") that allows you to choose a new Layout -- choose "Oslo", and hit "Try it out", and eventually "Yes, keep it."

enter image description here

| improve this answer | |
  • Thanks for the trick. Going to /_layouts/15/navoptions.aspx shows that the Quick Launch is still disabled. BTW, I see the left pane in the "New" SharePoint design. If I click to "Return to classic SharePoint", the left pane is hidden as expected. So the problem is in the new 2019 view. – MAS Services Feb 6 at 14:26
  • What template is this built on? Team, Communication, etc.? Normally in Modern Sties, we have the opposite problem of figuring out how to turn Quick Launch ON. – willman Feb 6 at 16:00
  • Is the "SharePoint Server Publishing Infrastructure" feature enabled in your site? – willman Feb 6 at 16:07
  • I added another option to my answer that uses the Change the look -> Site Layout option, give that a try. – willman Feb 6 at 16:23
  • My sites were built using the Document Center. We use mainly SharePoint to store our important documents. When switching to Oslo, the navigation menu on top disappeared. "SharePoint Server Publishing Infrastructure" is Active. – MAS Services Feb 7 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.