2

Trying to open an excel file from sharepoint and I've changed the default to open in the excel desktop app and not excel online. When I click the file to open it, up pops a permission request saying "Sharepoint wants to open this application" with "Open Excel" or "Cancel" as the only options. There is no "remember my selection" check box.

Any idea how to make it not ask me every time?

2 Answers 2

4

This is a browser feature and has nothing to do with SharePoint. Think about what could happen if web browsers could arbitrarily execute programs on the user's machine without their knowledge or consent.

2
  • I'm aware of the implications of that. Usually for something like there is a "allow this site to do so" without having to be asked every time since it's quite common need to regularly allow a web browser to execute programs. Do you know if there is a browser setting I can change? Thanks.
    – Nick
    Feb 4, 2020 at 19:28
  • Edge opens the document without any further dialogs.
    – teylyn
    Feb 4, 2020 at 21:09
2

This is a browser issue, but not for the reasons given in the other answer. It's to do with the integration of SharePoint and the respective browser.

Using Edge, for example, there is no further dialog. The document just opens in the desktop app.

Chrome, (if it is in the mood to actually honor the setting to open documents in the desktop app, which it often ignores and opens in the browser, anyway), will show the dialog to confirm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.