1

I am trying to share a SharePoint online sub-site which in turn shares the main site as well to my external clients, is there a way to share only the sub-site explicitly?

Any help will be appreciated.

Thank you

9
  • How are you sharing the subsite? are you giving permissions to users directly or giving permissions to SharePoint group?? Feb 4, 2020 at 10:24
  • I am navigating to the specific subsite after which I am just clicking on share and then adding in the required external mail address while doing this it does say me that this will share the main site as well. Feb 4, 2020 at 10:32
  • Are you using modern experience? I am not able to see any Share option in sub-site homepage. Can you please add any screenshot or something how you are granting permissions to user? Feb 4, 2020 at 10:35
  • Yes I am using modern experience Feb 4, 2020 at 10:35
  • Are you adding the user in any Site collection level SharePoint group?? Feb 4, 2020 at 10:37

3 Answers 3

1

According to your explanation, I am guessing you have granted permissions to your end user through a group in Site collection.

In SharePoint, sub-sites inherits its permissions from the site collection. Also when you create a group anywhere in SharePoint it will store this group at site collection level. So a SharePoint Group can be used anywhere in the site collection. This does not span over different site collection though.

Solution:

  1. Create a new SharePoint group in sub-site and grant permission to that group on sub-site level only. then add your users in that group. don't grant any permissions to this group at site collection level (or maybe they should have Limited access).

  2. Break Permission inheritance on sub-site level and grant only necessary permissions to end users on sub-site.

Reference: What is permissions inheritance?

2
1

Let me tell you the right way to do this.

Prerequisites-

  1. Enable external Sharing for SharePoint Online site collections and SharePoint online sites.

  2. Stop inheriting permissions since once you stop inheriting permissions, the changes made to the permissions of the parent site in the future will not apply to this subsite.

After this is done follow the steps below and check if it is indeed working out for you(technically it should only share the subsite and not the site).

  1. Go to the Site permissions>Grant permissions>Enter the external user's email address and select a proper permission>click share.
  2. Let the user go ahead and accept the invite.

Check if user is then only able to access the subsite or is he still able to access the parent site.

Let me know how this goes.

0

Just like other replies showed, you will need to create new SharePoint Group to hold all users who you only want to grant access to sub site. And break the permission inheritance in your sub site.

Steps will be like this:

  1. Break the permission inheritance. Go to the sub site, click on the gear button on right top of the banner. Go site permission>Advanced permission settings. Click on the button "stop inheriting permission" button in permission ribbon. There may pop up a page asking you whether to leave existing group for your sub site or create new groups. You can choose according to your requirements. Then click OK

enter image description here 2. Again go back to permission advanced settings, click on the create group button and configure the new group works for your sub site and then add members to the group

1
  • Thank you very much @jerry Feb 6, 2020 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.