0

I am having an issue with the search crawlers not stopping - they run with the status at "Crawling Full" status for days (125 hours, 271 hours, etc.) before I just stop them.

What I have done so far (Not necessarily in this order) -

  1. Stopped and started all SharePoint Search Services on the servers
  2. Cleared the server cache
  3. Changed the Content Source to point only to the root (there was another URL in the list that was suspect)

does anyone have any suggestions for how to resolve this?

Thank you - any help is welcome.

0

I would start with trying some of the solutions SharePoint 2013 Full Crawl never stops.

In particular...

Check the ULS Logs for more information on the App server(s) via c:\program files\common files\Microsoft shared\web server extensions\<VERSION>\LOGS and you may find more information on the issue.


If that doesn't help, I'd try Clearing the cache and rebooting using these steps:

  1. Stopping the SharePoint Timer Service on all servers
  2. Navigate to %SystemDrive%\ProgramData\Microsoft\SharePoint\Config and enter the folder with a hyphenated GUID like 42d05b3f-d221-4f69-845e-3f5bab1a4634 as a name.
  3. Delete all files within that folder EXCEPT for cache.ini. For safe measures, I'd back up that file as we'll modify it later. (link states you can copy/paste into same folder to create a - copy file.
  4. Now delete all the .xml files (sort by document type to make sure you don't select the .ini file.
  5. Open the config.ini and replace the large number inside with the number 1.
  6. Repeat 2-5 for each server
  7. Restart the SharePoint Timer Service on all servers.

The services will start to repopulate the configuration cache and will likely have a different number than what was in the original cache.ini.


As more of a last resort, try Re provisioning the search service by deleting it and building the new service through Central Admin > Manage Service Applications.

|improve this answer|||||
  • I had the problem the last time I built a SharePoint VM development server. The "last resort" was the only thing that fixed it. – willman Jan 31 at 1:35
  • I actually did steps 1-7 already on all servers ... this did not help - would an IIS reset be necessary? Or restarting the servers? – Anngela Jan 31 at 14:41
  • @Anngela It shouldn't be necessary. You can try an IIS reset and see if that helps. However, as willman said in a previous comment he had to do the 'last resort' option to fix this. – KGlasier Jan 31 at 15:31
0

First check what is the state of each database of search service from the search service administration page in CA - then try to follow the below :

  • Clear Cache in all App servers , Index Reset and start full crawl.
  • Restarting the servers.

If that does not resolve, check the below :

  • C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\LOGS

  • Restart SharePoint Server search service

  • Restart SharePoint Timer Service

  • Restart IIS

If the above steps doesn't resolve issue, try to run configuration wizard in App server but ensure while running the configuration wizard take all necessary backups.

Finally, if nothing works - need to create a new search service application and we can delete the old one, here while recreating the new SA, we can reuse the same search service db in order to retain all configuration.

|improve this answer|||||
  • a new content source (test) was created for the search service using the root URL that completed a full crawl in just over an hour (it literally is set up the same way as the original with a different name) ... not sure why that one is working but the original does not. – Anngela Jan 31 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.