1

All of my lists are in Quick Edit view by default and I want to change it to be the Standard View by default (see standard view image below).

I read a solution that tells me to go to Advance Settings > Quick property editing, and set it to "No." When I do so, it still defaults to Quick Edit mode, but I can't see data and I cannot exit Quick Edit mode via the "exit quick edit" button/option. The button just doesn't work.

Besides, I do want to quick edit option (see standard view image), I just do not want it to be in quick edit mode initially.

Where can I make this change globally? Or even at the list settings level.

Quick Edit View

Quick Edit View

Standard View

enter image description here

  • Do you have All items view in your list? – Ganesh Sanap Jan 30 at 15:52
  • If I create a new view, set it to the Standard View type, and make it the default view for the list, it solved my issue for that list. How can I make this the default for all lists site wide? I'm guessing having it default to quick mode is not the norm, so there must be a site level setting, no? – Jason Jan 30 at 16:03
  • Yes, standard All Items view should be the default view of newly created list. – Ganesh Sanap Jan 30 at 16:08
  • How are you creating a new list? From browser/UI or by using any code/script? – Ganesh Sanap Jan 30 at 16:09
0

If you want to make another view (probably All items view comes with SharePoint list when you create it) then follow below steps:

  1. Go to List and from there navigate to List Settings.
  2. From list settings page, scroll down to the Views section and click on the view name you want to make default.
  3. Check the Make this the default view checkbox below view name on view settings page.
  4. Click OK.

Note:

If you don't have any other standard view in list then you need to create a new list view on your own.

Check below official documentation to create a new view (Select Standard View type while creating a new view):

Create, change, or delete a view of a list or library.

|improve this answer|||||
  • Also keep Advance Settings > Quick property editing set to Yes. – Ganesh Sanap Jan 30 at 16:02
  • Please Upvote and accept it as an answer if it helped you. – Ganesh Sanap Jan 30 at 16:05
  • Yes, that fixes it at the list level, which is great. How can I change this for all of my lists at the site level? Is this the normal default? All my lists are in quick edit mode when I go to them by default. – Jason Jan 30 at 16:09
  • How are you creating a new list? From browser/UI or by using any code/script? Are you using any site design script or anything to create list? How it is setting quick edit mode as a default view? – Ganesh Sanap Jan 30 at 16:20
  • 1
    I believe my issue is very specific to something weird on my end related to templates for lists. I resolved it but I am not sure how. In terms of how to change this on a per list basis my question was answered. And so I accepted the answer above. Thank you. – Jason Jan 30 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.