Recently I find one issue in my Central Admin, i.e "Product / patch installation or server upgrade required on one of our Application Server. Even I did run the PowerShell cmdlet Get-SPProduct -local and refreshed configuration wizard as per Blog but, Issue still existed and configuration wizard getting errors. Please advise me.

enter image description here

Thanks in Advance

Srinu Dasari.

  • Have you ran the wizard on the servers that are 'missing' the patches? If yes - did you try with the get-spproduct -local and than rerun the wizard? I've had this happen quite a lot (2013). However, I've had occasions too were after upgrading a server, there were additional patches that needed to be applied. Commented Jan 30, 2020 at 13:36
  • Yes @Christoffer I did. But, configuration wizard ends up with an error message that states , patches are missing. Commented Feb 6, 2020 at 9:26
  • The patches that are missing: google the KB number and download and apply those patches to the servers where they are missing. I had this happends once before. Commented Feb 6, 2020 at 9:51
  • But, Here is the problem, when I try to install KB, getting error that was saying already installed. Commented Feb 6, 2020 at 10:09
  • Have you tried to reboot the server(s)? Either that or run the wizard using the psconfig/sharepoint cmd shell. Commented Feb 6, 2020 at 12:43

3 Answers 3


After days of struggling, I found that Installer folder under C:\Windows directory is missing. So, here How I closed issue:

  1. Create an empty folder under C:\Windows directory.

  2. Copy files from C:\Windows\Installer folder from another working server to present server.

  3. Restore-InstallerFiles.ps1 powershell downloaded by from Here

  4. Run Restore-InstallerFiles.ps1 to installe missed installer files.

  5. Run Get-SPProduct -Local from SharePoint PowerShell.

Now Missing/Required error disappeared and able to run Configuration Wizard without any issues.

Thanks For Everyone


This error usually pops up when you have not installed the patches in the right way.

Although it doesn't matter but I have always followed the practice of installing the patch on the Application server first(where CA is hosted) and then installing it in the remaining WFE servers and so on.

The best way to solve this issue would be to uninstall the installed patches and install the update again starting with the Application server.

Let me know if you are able to resolve the issue.

  • Thanks for reply, @yash.kamdar, unistall patches on which server? Commented Feb 6, 2020 at 9:28
  • I guess you already posted an answer that worked for you. Nice work !!! Commented Feb 24, 2020 at 11:14

Just run in SharePoint V Management Shell this command after your sure all updates are installed on servers farm:

PSCONFIG.EXE -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures -cmd installcheck -noinstallcheck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.