0

I have SharePoint 2019 environment migrated from MOSS 2007. I have also configured the User Profile service application and sync all users from AD. For some reason the User Property like "Title / Department" is not showing in Site collection user info list (hidden) also People & Groups page. Also, i have tried following options

  1. delete the user from Site Collection (User Information List) throws an error "This operation is only for the web with unique permission"
  2. run "stsadm -o sync"
  3. $user = Get-SPUser -Identity "domain\user_name" -Web $url Set-SPUser -Identity $user -SyncFromAD -Web $url
  4. stsadm -o sync -listolddatabases 0 - all database synced recently

But no luck!! can anybody help with this!!

Is there any problem with Claim token in Account name?
When checking the account name

User Information List : i:0#.w|DOMAIN\user_name
User Profile Service: DOMAIN\user_name

0

There are two jobs, User Profile to SharePoint Quick Sync and User Profile to SharePoint Full Sync, that synchronize the User Profile database information with the UIL. Sometimes this stops working (properly) and in that case you need to run:

stsadm -o sync -listolddatabases 0

stsadm -o sync -deleteolddatabases 0

The first command will list Content Databases that haven't had the UPA -> UIL sync occur in 0 or more days.

The second command will delete the records corresponding to those databases (it doesn't delete databases/end user data).

Do USPA Full sync and check the user properties.

Reference:

User Information List not sync'd with User Profile database

http://ramdotnetdeveloper.blogspot.com/2016/06/user-information-list-in-sharepoint-2013.html

https://thesharepointfarm.com/2014/01/troubleshooting-user-property-issues/

0

There might be various reasons for this issue. I would first verify if the values of these two fields have been imported and aligned with the AD values by searching and viewing a user profile in the "Manage User Profiles" page in the Central Admin. If they are, then the timer job synchronizing user profiles with SharePoint User Information List is not working properly.

Also, you can create a new user profile (user exists in AD) from the central admin and see if the values are imported from the AD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.