3

I have seen this question asked several times, here or somewhere else on the Internet, but none of the solutions presented worked for me.

What I have :

  • SharePoint 2013 OnPremise
  • Workflow Manager installed on a front-end server.
  • Several site collections, and on one of them (call it SiteColl01), all the workflow features activated.
  • On one SiteColl01's subsite (call it SubSite01), I have 2 document libraries : OfficialLib and TestLib (testLib was created after OfficialLib, to try several solutions for the workflow)

On each of these libraries, I have created a standard 2010 Approval workflow, with same settings in each of them. I created this workflow using the Library Settings and nothing else. I insist on the fact that these workflows are STANDARD Sharepoint. No Sharepoint Designer involved (and SPD is not even installed on either of our servers)

What error I got :

On a really randomly basis, I got the error "Workflow failed on Start" and "Workflow cancelled by System Account" error messages from Wkfw History List.

What I tried :

I tried several things :

  • The Get-WFFarmStatus got me the following :

MyFTEServer.MyDomain.com > WorkflowServiceBackend > Running

MyFTEServer.MyDomain.com > WorkflowServiceFrontEnd > Running

  • The Get-SBFarmStatus got me the following :

MyFTEServer.MyDomain.com > Service Bus Gateway > Running

MyFTEServer.MyDomain.com > Service Bus Message Broker > Running

MyFTEServer.MyDomain.com > Service Bus Resource Provider > Running

MyFTEServer.MyDomain.com > Service Bus VSS > Running

MyFTEServer.MyDomain.com > FabricHostSvc > Running

  • And here are the results of the Get-WfFarm cmd.

FarmType : Workflow

WFFarmDBConnectionString : Data Source=MySQLServer;Initial Catalog=WFManagementDB;Integrated Security=True;Encrypt=False

RunAsAccount : EUR\MyFarmAccount AdminGroup : BUILTIN\Administrators

Hosts : {Name: MyFTEServer.MyDomain.com, Configuration State: HostConfigurationCompleted}

InstanceDBConnectionString : Data Source=MySQLServer;Initial Catalog=WFInstanceManagementDB;Integrated Security=True;Asynchronous Processing=True;Encrypt=False

ResourceDBConnectionString : Data Source=MySQLServer;Initial Catalog=WFResourceManagementDB;Integrated Security=True;Asynchronous Processing=True;Encrypt=False

HttpPort: 12291 HttpsPort : 12290

OutboundCertificate: Thumbprint: 6520133EE703BF0184E3C1105F22219C6B9AA51E, IsGenerated: True

Endpoints :{https://MyFTEServer.MyDomain.com:12290/} SslCertificate : Thumbprint: 9B4C9BA9C07C76B3062FA6F9615A462E23888DBB, IsGenerated: True

EncryptionCertificate : Thumbprint: 9B4C9BA9C07C76B3062FA6F9615A462E23888DBB, IsGenerated: True

  • I read on the Internet that a CVS update from october 2018 caused an issue SharePoint workflows stop working after you install .NET security updates for CVE-2018-8421 but I checked and we did not install the security update (I know, we should, but this is not the point currently).

  • I read too that you have to reset SPD cache, but since no workflows has been made using SPD, I think this is irrelevant.

  • I tried to create a new Approval Workflow 2010 (with same parameters as the other ones), but using a user with high permissions.

  • I tried to create a new Approval Workflow 2010 (with same parameters as the other ones), but using a service account (the farm service account, to be more precise).

Results : Nothing worked, I still get the same random "Workflow failed at start" and "Workflow cancelled by System Account". Random, because either me or a Member of the site are getting these messages from time to time. We could not reproduce this issue with an accurate frequency.

TLDR : On my SP2013 OnPrem farm, my Approval Workflow 2010 fails on start, cancelled by a System Account, completely randomly. Tried several internet recipes and did not work.

So, please, can you help me understand why are my standard Approval Workflow 2010 failing on start, cancelled by a system account ?

Thanks a lot and sorry for the long post (I have unfortunately no potato to give to any of you, but my eternal gratitude)

3
  • 3
    One important thing here would be to grab the relevant ULS logs: note the time window the error occurred at, and try to find in the ULS the error related to "Workflow cancelled by System Account" (this exact string may not be found though: you'd better look for "Legacy Workflow Infrastructure" events in the correct timeframe). Could you then please share all related log lines with us? Don't forget to look on all SP servers if this is a multi-servers farm.
    – Evariste
    Feb 12 '20 at 11:03
  • Agreed with @Evariste, You need to actually check the ULS logs to see what's going on under the hood. Feb 12 '20 at 11:10
  • And it might still be the cache: social.technet.microsoft.com/Forums/office/en-US/… Feb 12 '20 at 11:17
2
+50

Last year I had a very similar problem, if not the exact same problem.

Overnight, all ootb SharePoint Workflows stopped working, with the error message:

Workflow XXX was canceled by System Account.

In our case, it turned out to be a security update,

SharePoint workflows stop working after you install .NET security updates for CVE-2018-8421

At the time we rolled back the update but in the update website there is a script you can use to make the necessary adjustments in order to make it work post-update.

Hope this helps.

enter image description here

edit: I see you mention this as well. I would still double check, and even apply the corrections mentioned as an attempt to solve the issue.

if it works in some cases but not others, you may have a different problem, but I thought I should leave my example here anyway

1
  • Hi @tiago-duarte ! Thanks for the input, but not sure the corrections will work (I even fear they will make things worse, because I haven't installed the CVE-2018-8421 which it's supposed to correct)
    – Gaelle
    Feb 17 '20 at 7:44
0

By default, System Account cannot trigger workflows automatically.

So, you need to make sure the account which trigged this workflow(not the workflow creator) is not System Account. You can modify the view of your library and set Created By and Modified By to show, then check the values of the two fields.

Also, please log on to your site using another account with full control permission and create/edit a document to trigger the workflow, check if this issue occurs.

2
  • Hi @Kally_MSFT, first thanks for your time. I tried what you said and added the columns "Created by" and "modified by" in my TestLib library. They are identical, and no System Account involved. Only in the Task library the tasks are created by "System Account" which is the SHAREPOINT\system". I definitively tried to log on a site using a SiteColl administrator and submitting several documents to approval, and as I said, it returned randomly this error. (sometimes it worked, sometimes absolutely not, I did not even get a task created nor an email sent)
    – Gaelle
    Jan 28 '20 at 14:13
  • 2
    System Account cannot trigger workflows automatically: I believe this is only true for SP2013 workflows (ones using Workflow Manager architecture). For 2010-style workflow, system account can trigger them.
    – Evariste
    Feb 12 '20 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.