2

I added the webpart "Document Library" to a page and made my settings, I deactivated the command bar, selected a library (the page library where the modern pages and news pages are stored by default) and saved the page. When I now look at the page and open the context menu in the library, I can see that it is in English.

englisch context menu

However, I have set my page to German in the website settings. How can that be? How can I fix this?

1
  • From where you set the language to German in SharePoint Online?? – Ganesh Sanap Jan 28 '20 at 6:16
1

I reproduced your issue by changing language settings for my SharePoint site. Maybe it is a SharePoint issue/limitation that after adding a library on a page, it shows the document menu in English only.

As a solution to this, I changed my browser language to German (same language as site) and then I could see the menu in German and NOT ENGLISH. Here's the screenshot of the same.

enter image description here

This is not a SharePoint solution but this is the only thing that worked out for me.

5
  • I tried Chrome, Firefox and InternetExplorer in german language, it did not work. I have switched the command bar on and off, the context menu and the bar were always in English. – SharePointNewbie Jan 28 '20 at 10:43
  • Chrome will give you an option to translate. This option will be there at the end of the address bar. Just click on translate. The site will get refreshed. – harshal gite Jan 28 '20 at 10:46
  • On your screenshot I can see that the command bar is in English?! – noSharePointToday Jan 28 '20 at 10:56
  • only 1 selected is in English. The screenshot was taken when only browser language was changed to german and site language was english – harshal gite Jan 28 '20 at 12:10
  • Also, looking at a document library in german directly, your context-menu seems to be automatically translated by the browser, because SharePoint actually uses "Öffnen" instead of "Öffnen Sie" und "Oben anheften" instead of "Oben anpinnen" - at least in my instance (target first release, so this might have been changed). – J. Tihon Feb 3 '20 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.