1

I have migrated a SharePoint 2010 site to SharePoint online, and we have a workflow which show correctly inside the list settings >> Workflow, as follow:-

enter image description here

But when i tried to edit the workflow using SP Designer 2013, i got this error :- enter image description here

now i tried to delete the cache from these 3 locations:-

  • C:\Users\\AppData\Local\Microsoft\WebsiteCache
  • C:\Users\\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache
  • C:\Users\\AppData\Roaming\Microsoft\Web Server Extensions\Cache

i also tried to edit the workflow from "SP Designer" >> "All Files" >> "Workflow" >> open the ".xmol".

but none of the above fix the issue for me. can anyone advice please?

1

I think this is the issue with SharePoint mismatch, since you have migrated it from SharePoint 2010. Try uninstalling the SharePoint 2013 designer and install it back.... and also see are you able to create any new workflow in the designer. If nothing works you may need to recreate the workflow using SharePoint 2013 designer workflow template. And also make sure you are only using SharePoint 2013 designer.. if you have got installed SharePoint 2010 designer as well, need to uninstall it.

Please verify the below checklist :

  1. Uninstall SharePoint Designer 2010 if installed.
  2. Uninstall SharePoint Designer 2013.
  3. Use Windows Explorer to open these 3 locations and delete all the files there:         C:\Users\\AppData\Local\Microsoft\WebsiteCache         C:\Users\\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache         C:\Users\\AppData\Roaming\Microsoft\Web Server Extensions\Cache
  4. Reboot the client.
  5. Install SharePoint designer 2013 with the latest updates packaged.
  6. Open SPD 2013, connect to the site and edit the workflow.

Similar problem is discussed in the below thread :

SharePoint designer cannot display the item - workflows

  • i do not have SharePoint designer 2010, so i clear the files from the 3 locations >> restart the server (where the SP designer is installed) >> but still facing the same issue. also when i create a new item , the workflow will have this status "Failed To Start" with a correlation error.. any idea? can i export the workflow and re-publish it? – John John Jan 24 '20 at 12:41
  • Try to uninstall sp 2013 designer and re-install it back... it will just take little time. – GSD - SharePoint Jan 24 '20 at 12:47
  • so you think the problem is with SP Designer and not the workflow? and if this is the case then why the workflow fail to run..? so seems the problem is within the workflow itself.. is my point valid to you? – John John Jan 24 '20 at 12:51
  • If this was a working workflow in SharePoint 2010, and after migration in online it does not work.... then it could be the problem with version mismatch of the designer tool not with the workflow.... By the way please try this also, create a sample workflow using your present version of designer. – GSD - SharePoint Jan 24 '20 at 12:56
  • but if the workflow is fine, then why it is failing to run when creating new items?? – John John Jan 24 '20 at 12:58
1

I believe your workflow was built on 2010 template

  • yes i think so, it was created by our customer... – John John Jan 24 '20 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.