I'm trying to share folders with specific people in SharePoint online (without granting site access). I am clicking on the 3 dots next to the folder, and selecting Share. I am then selecting "specific people". By default the edit option is ticked.

When I share this link, the user opens the link but the edit permission somehow keeps reverting back to "view" only.

I can open the manage option, and navigate to that user, and the settings have changed to view. When I change it back to edit, it again changes back to view only.

The settings worked perfectly for months, and then only recently this issue appeared, and all of our users can not edit now.

I have also tried to add the person directly, by selecting Manage from the folder, then choosing "advanced" at the bottom right hand panel, and then adding them directly with "contribute" permissions, however it is still not allowing any editing rights.

Everyone that was previously added with edit rights were listed as "links giving access - people you specify can EDIT", but now have all changed to "Links giving Access - People you specify can VIEW"

Does anyone have any idea what is going on here? I have another site that doesnt have this behavior - and Ive compared all settings in permissions/library setting for the 2 sites and nothing is different.

Im hoping for someone to solve this for me, as Ive had little help from Microsoft.

Thanks for your help

1 Answer 1


Whether this issue occurred on only external users or both internal users and external users?

Go to SharePoint admin center->Sites->Active sites, find the site and click “Sharing” button on the ribbon, check if the default link permission is Edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.