1

I've been preparing an upgrade from SharePoint 2013 to 2019. So far I've managed to attach the database to 2016 and successfully upgraded it.

I was able to use the site collection without any problems. So I dismounted the database from 2016 and mounted it to 2019. Upgrade steps where successfully executed and I even ran psconfig (Gui) just to be sure.

My problem is that I get an access denied message when I try to open the site with farm/site collection administrator. Removing the site collection administrator and adding him again didn't help.

http://hostname/_layouts/15/AccessDenied.aspx?Source=http%3A%2F%2Fhostname&correlation=c24e2c9f%2D6a56%2De0b3%2D1e0f%2D6703bab98e37&Type=list&name=%7BCC5EEC1C%2D42B9%2D4933%2D9B7C%2DBF8FE30E40C7%7D

The access denied url contains a list guid which (using Powershell which works just fine) I traced back to the master page gallery. It seems I lost access to my master page gallery, which doesn't make a lot of sense to me. Can anyone help?

Update: Not sure if it's relevant, but it's a host named site collection.

2
  • Try to hit this URL in your browser: siteUrl/_catalogs/masterpage/Forms/AllItems.aspx. This link is of Master Page Gallery. and see if you or any other user in your site can access it? – Ganesh Sanap Jan 30 '20 at 9:06
  • Not sure if this is related (I think we once had a similar issue, but can't figure out if this correlated), but are your Cache-Accounts (SuperReader, SuperUser) correctly set at web application level, have the corresponding permissions i the web application and aren't locked out? Check this article for reference: docs.microsoft.com/en-us/sharepoint/administration/… – Christian Berger Feb 4 '20 at 12:17
1

Try to check if your user is a member of the owners group and the owners group has permissions on the masterpage gallery.

It should be set via Site collection admin, but just to verify.

1
  • Hey Christof, the user is a member of the owners group and the group has full control on the list. – Andreas Jan 17 '20 at 20:59
1

Please follow the upgrade instructions. The basic steps are:

  1. On SharePoint Server 2013, use Convert-SPWebApplication to convert from Windows classic authentication to Windows claims (if using Windows authentication and if not previously done during a 2010 -> 2013 upgrade). This is a requirement prior to moving content databases to SharePoint Server 2016.
  2. On SharePoint Server 2013, use Upgrade-SPSite to upgrade all site collections from V14.5 to V15 mode. This is a requirement prior to moving content databases to SharePoint Server 2016.
  3. Migrate the CDBs to the new SQL Server supporting SharePoint Server 2016 and attach to an existing Web Application using Mount-SPContentDatabase to upgrade the content databases.
  4. Once the databases are mounted, move them to the SQL Server supporting SharePoint Server 2019 and again on an existing Web Application, use Mount-SPContentDatabase to upgrade the content databases.
4
  • Hello Trevor, beside this already being claims based I this is what I've done. I guess something is wrong with either 2016 or 2019 farm, because the behavior is the same for a new sp2016 site collection migrated to 2019 – Andreas Feb 2 '20 at 7:40
  • Have you granted yourself Full Control over the Web Application so you can browse the sites w/o needing a specific site-level ACL? – Trevor Seward Feb 2 '20 at 19:30
  • I've even created a new web app for this reason – Andreas Feb 3 '20 at 6:14
  • Hey Trevor, I went ahead and recreated the whole farm and sure enough everything started working as expected. Not sure what to take away from this. – Andreas Feb 20 '20 at 9:10
1

Can other users open the migrated sites successfully? Or are it just farm-account and site-collection admins?

Does the service-account used for the application pool have db_owner permissions for the content database? On occasion I've seen SharePoint wanting to make some minor upgrades to the database schema upon first access of items and then failing if the app-pool user does not have the permission to do that.

1
  • Hey J, sorry for the late reply, but permission had been checked multiple times and they didn't seem to be the reason – Andreas Feb 20 '20 at 9:09
1

I was going through same issue.

The resolution was to connect the existing migrated UPS with the migrated database web application and run the full sync from UPS.

This has solved my issues from sp 2013 to sp 2016 db migration which has same issue. Migrating same Databases from 2016 to 2019 farm caused same issue. I used the migrated User profile service DB and ran the full sync from UPS.

0

Have you tried to access other location in that site collection like lists,libraries? There may be issues with the homepage of the site collection.

2
  • Hey Jerry, yes I tried different lists and libraries, but ultimately it seems to always come back to trying to access masterpage gallery and failing. – Andreas Jan 29 '20 at 9:13
  • Via powershell I changed masterpage gallery to inherit permissions, but it didn't help either. – Andreas Jan 29 '20 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.