0

Looking for some help. We recently moved a SharePoint 2013 environment from Windows Server 2008 to Windows Server 2012. Whilst testing I setup some new alternate access mappings to test with, for instance:

Today however we are going live so I have reverted the Alternate Access Mappings back to the default, when testing the workflow we are continuing to get the old URL which eventually leads to the Workflow becoming suspended:

Workflow Error

The bindings to the old URL have been removed on all servers and I have registered the workflow service with the new new correct url.

Any advice and help would be appreciated.

1

I got this working by registering the workflow service with a new scope for instance:

Register-SPWorkflowService -SPSite "http://my.sharepoint.com" -WorkflowHostUri "https://myworkflowhost.com:12290" -scope "SharePoint01" -AllowOAuthHttp -Force
0

Re-register SharePoint Workflow with -Force Key on existing URL on the workflow member server,

Register-SPWorkflowService –SPSite "http://my.sharepoint.com" –WorkflowHostUri "https://my.sharepoint.com:12290" –AllowOAuthHttp -force

Check AAM settings, any reference for the old url present?? Only place for the workflows to get the url would be from the AAM and the url which we give while registering, that's it.

For more information, refer the below links,

https://www.netwoven.com/2016/01/08/sharepoint-2013-alternate-access-mapping-aam-dos-donts/

How I can show the alternative access mapping url inside a “current item url” inside workflow 2010

How I can show the alternative access mapping url inside a “current item url” inside workflow 2010

  • All AAM are as expected and only have the correct URL. I have tried registering the workflow service with the force parameter, still no luck. – Adam13Hylo Jan 12 at 18:40
  • Have a look at the URL's I have suggested, you will get a clue. – Karthik Jaganathan Jan 12 at 18:44
  • SharePoint workflow always pick the default zone url. – Karthik Jaganathan Jan 12 at 18:48
  • Hi Karthik, I only have 1 URL set and that is in the default zone. I have also tried removing the workflow server from the farm and adding it again. Still no luck. – Adam13Hylo Jan 12 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.