1

A couple weeks ago a user reported that they could no longer open document libraries in Windows Explorer, when using IE as a browser. I verified I could also not do this. After restarting machines - including the sharepoint server - the problem persists. When the "Open with Explorer" link is clicked for a library a popup appears telling me "We're having trouble opening this library in File Explorer" with learn more link and a recommendation to sync with onedrive. Syncing doesn't fail but I think we did not do the right setup to make that work in our environment, so it doesn't actually result in seeing the files in the library. The learn more link suggests something about adding the site to trusted sites, and says some things about IE10. There's also the webclient service, which was already installed or running on client machines. Had IT add it to the sharepoint server as well.

Users can work around this issue by using a shortcut to the folder in windows explorer via a UNC path.

The environment is SharePoint Server 2016 on-premises and windows 10 clients using IE 11. The task in question has been working until approximately 12/20/19 or thereabouts. No updates have been made to the SharePoint installation recently, and server updates were rolled back with no appreciable change in outcome.

Is this something Microsoft has done? Or is there perhaps something I missed when I tried to correct the issue?

0

Make sure the “Desktop Experience” feature is installed.

Go to Server Manager -> Features -> Add Features -> Install Desktop Experience. After adding the feature, you need to restart the server.

Make sure the WebClient service is enabled and started.

Click Start -> Control Panel -> Administrative Tools -> Services->start the WebClient service.

Besides, using 32-bit Internet Explorer to compare the results.

Refer to the following articles to further troubleshoot the issue:

https://support.microsoft.com/en-sg/help/2629108/how-to-use-the-open-with-explorer-command-to-troubleshoot-issues-in-sh

https://blogs.technet.microsoft.com/asiasupp/2011/06/12/error-message-your-client-does-not-support-opening-this-list-with-windows-explorer-when-you-try-to-open-with-explorer-on-a-sharepoint-document-library-in-office-365-site/

https://www.enjoysharepoint.com/we-re-having-a-problem-opening-this-location-in-file-explorer/

| improve this answer | |
  • Is the Desktop Experience feature something that might randomly get turned off during a server update? This is a feature that's just always worked for years. – Matt Jan 11 at 6:05
  • It might have disabled in the latest update. Kindly check it. – Karthik Jaganathan Jan 11 at 6:49
  • it's unclear where the desktop experience can be found on server 2016 – Matt Jan 13 at 19:54
  • yeah all the things mentioned here are installed, still no dice. I'm gonna also install the latest CU. – Matt Jan 22 at 21:40
0

Restart the computer and compare the results.

Similar issue post for your reference:

https://social.technet.microsoft.com/Forums/en-US/c9bc364f-7153-484d-a849-18e340592524/sharepoint-2016-open-library-in-explorer-error?forum=SP2016

| improve this answer | |
  • Seems like the other guy simply copied your response there. – Matt Jan 13 at 19:06
  • WebClient service was installed but not running. I started it, no change, also restarted the server, no change. – Matt Jan 13 at 19:28
  • yeah all the things mentioned here are installed, still no dice. I'm gonna also install the latest CU. – Matt Jan 22 at 21:40
0

Make certain that when viewing the site in Internet Explorer, if you open the Developer Tools (F12) the document mode is set to 10, not 11 or Edge. This should be visible in the Emulation tab of the developer tools.

There are a number of reasons why it might default to something other than 10, and the solutions vary. Typically an x-ua-compatible tag in your masterpage can force IE into IE10 mode.

Internet Explorer also has Compatibility View settings which may have changed on the client PCs; the settings can include a list of domains to display in compatibility view, and a checkbox to display intranet sites in Compatibility View.

| improve this answer | |
  • Appreciate it but changing the document mode did not make a difference. It was already 10 because of x-ua-compatible. Compatibility view is already out of the picture because we discovered a number of SharePoint related issues with that in the past. – Matt Feb 4 at 18:33
  • 1
    If you open up Windows Explorer, can you manually navigate out to SharePoint by using a UNC path (e.g. \\server\site\library for HTTP or \\server@SSL\site\library for HTTPS) in the address bar? (If you can't, that usually suggests a problem with WebClient on the client PC, as the other answers have already touched on.) – Thriggle Feb 4 at 18:47
  • Yeah the users who use this feature regularly are already using this as a workaround (one of them had saved the shortcut on their desktop). – Matt Feb 4 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.