We are finishing up building a fresh SharePoint 2016 on-premise solution. Everything is working except search, which seems completely broken.

As far as we can tell all service account permissions are correct for search, but we can never get any results.

The crawling is successful, all of the websites get hit, but nothing ever comes out of the search regardless of the search term.

The only thing I can think is some obscure permissions issue or even though the websites are getting crawled their content is not getting indexed and is somehow unavailable for the most basic search or search itself is just wired up incorrectly.
enter image description here  I loaded up the ULS Viewer and poked around and two things jumped out. The query seems to be going in, it just never has any results.

"Microsoft.Office.Server.Search.Query.Ims.ImsQueryInternal : Number of tables in Result: 4, Relevant Results: 0 (Total: 0, Total including duplicates: 0), Refinement Results: 0"

How can I verify there is any searchable content after a crawl? Also I now have 2 Search Service Applications and am not entirely sure how to wire these up to the different search boxes.

Any advice is greatly appreciated.

  • 1
    If you're getting crawl success, yes the successful items have made it into the index so permission-wise for your crawl account, it's correct (or at least Full Read). Have you set up an Enterprise Search center and searched for something generic like docx? You can verify searchable content in the URL View in your screenshot above.
    – user6024
    Commented Jan 4, 2020 at 18:02
  • @TrevorSeward When I go into URL View and search on "docx" or really anything it works correctly. It all falls apart when I try setting up a basic or enterprise search. Commented Jan 4, 2020 at 18:28
  • Just tried creating a fresh new enterprise search and when I search on docx I get no results. How do I verify it is wired up correctly ? Commented Jan 4, 2020 at 18:38
  • 1
    Is the Search Proxy attached to the Web Application? There's nothing at the site level you need to do.
    – user6024
    Commented Jan 4, 2020 at 19:28
  • @TrevorSeward Yes, the original search proxy was attached. So I set it to use a different search proxy I had created (as part of my troubleshooting process) and it worked. My thought is putting it back to the original and it will also work. Either way, thank you so much Trevor ! You made my coming week much less stressful ! Commented Jan 4, 2020 at 20:16

2 Answers 2


Where do the users search from? From search center or from a site search? Please offer a screenshot about the error page.

Try to create a new search center and search from the new search center, compare the results.

Make sure search related service is started.

Make sure your Search service application is connected to web applications.

Navigate to Central Admin > Application Management > Manage web applications >Highlight the web application > Select Service Connections from top ribbon > Make sure your Search service application is selected.

enter image description here


Please check your TCP IP 808 port configuration both in WFE and Application servers. Other Port need to be checked TCP 32843 and 32844

For all required port details in SharePoint 2016, please refer the below article :


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.