It seems like anonymous access to SP lists is an excruciating pain for all besides the security reasons. My boss wants a single form in the list be public and redirect to a thank you page once an anonymous user submits the form. I managed the redirection and submission successfully. I enabled anonymous access to that particular list. When an anonymous user submits the form, SP gives the following error instead of redirecting to a thank you page.

The data source control failed to execute the insert command.

Is it a worklow issue since the list used to be private?

Any suggestions?

1 Answer 1


Disclaimer: Never tried it but worked for one of my colleague. Might loose some running instances of workflow

Go to Settings > List Settings

Under Permission and Management, select Workflow Settings

Find the name of workflow there, and then click on Remove a workflow

Mark all instances to Remove

Try re-attaching workflow to the list. Try initiating again and hopefully it should work.

  • didnt work :( what about lists with no workflows.
    – user21126
    Nov 29, 2013 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.