3

I am installing SharePoint 2019 on 3 separate servers

  1. Active directory
  2. SQL server
  3. SharePoint server.

at first I config active directory and then join my SQL server and SharePoint server to active directory domain. my SQL install successfully and SharePoint install successfully too, but when I want config my SharePoint, in specify configuration Database setting I got ERROR. database server: computer name of SQL server database name: default username: domain\user enter image description here

please help me, what I am wrong?

  • try to ping 'sql' or open shared folder from SP server. What is the result? – Raf Dec 18 '19 at 6:16
3

This issue usually occurs in case of:

The Database Server is not reachable from the SharePoint Application Server.

The SQL Server port is closed and is not accessible from SharePoint Application Server.

Please check How to Check SQL Server Instance Connectivity from the application server to database server for a specific user.

SQL Server Service is stopped.

SQL Agent is stopped.

SQL Server Browser is stopped.

SQL Server Network Configuration TCP/IP is disabled.

SQL Server server was blocked by Firewall. The provided account doesn’t have sufficient permission.

Please check Can not connect to database master at SQL server in SharePoint

2

from the error, it is giving the hint that their is problem with SQL server connection from your SharePoint server. Couple of things to check.

  • Make sure their is no firewall block between SharePoint and SQL
  • Make sure port 1433 is not blocked by any software or firewall.
  • All the required SQL services are up and running on SQL server
  • Account you using to connect SQL should have the right permission (DB creator and Security Admin)
  • server is ping-able and accessible over the network.
  • also reboot the server if you make any changes on the server.
0

Check have you completed your ADDS controller and verify your SQL Server name username Domain\Username enter properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.