0

I have a site collection with custom web parts (which do not alter permission groups but use them) and custom permission groups in Sharepoint 2013. There are no subsites.

When I add a user to a reader group I expect him to be able to access the home page. But he is unable. Neither directly to the page (http://siteColletion/Pages/home.aspx) nor from te redirect (http://siteCollection).

The pages library inherits permissions. There are no items that break permissions in this library.

The way I found the user is able to access the page is to make him join a collaborator group, enter http://siteColletion/Pages/home.aspx and then remove him from the group. Note that http://siteCollection at this time does not let the user access the site collection, but does after going through http://siteColletion/Pages/home.aspx.

Checking permissions before and after the process for the user returns the same groups and attached permissions.

The question is: What I have to do so I can add users directly to a reader group and have them being able to access the home page?

Note: The screen that shows when the user has no permissions is "Let us know why you need access to this site."

More tests:

Cached user: Adding user once to a collaborator group and accessing the home page is enough to make him always able to access home while he is in a reader.

SuperCached user: Reseting IIS won't make the user unable to access again

  • does homepage contain the custom webpart which uses the custom permission groups? – Deepika Dec 17 '19 at 11:40
  • @Deepika Yes. Also just realised that one webpart writes the user language preference in a list the first time he enters. A cooworker says that web.AllowUnsafeUpdates should be enough, though. (I will try with runWithElevatedPrivileges) – the simple Dec 17 '19 at 11:47
  • also check the custom permission group settings and set Who can view the membership of the group? to everyone. for the groups which are used on the homepage. – Deepika Dec 17 '19 at 11:50
  • @Deepika It works that way, right now. – the simple Dec 17 '19 at 11:59
  • 1
    After some testing it looks like the custom webpart that tries to write in a list is to blame. – the simple Dec 17 '19 at 13:11
1

Here are some of the scenarios which can be causing this issue. You can perform the below step to identify the root cause.

  1. Try to access the list directly using URL from which you are just expecting a user to read the data. If that is successful then there is no issue with permissions.
  2. Identify that, the custom web parts on your home page are just fetching the data from the lists. If any of the web parts are inserting any data to list then it will not work for the users added in Reader group.

You can use run with elevated privileges function if you need to enter any data to List using that it will bypass the permission issue of the user from the Readers group.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.