0

I have created the retention policy through the "Information Management Policy Settings" in the "Library Settings".

The policy details below:

Event: "Custom Date + 0 days"
Action: "Declare Record"

Here, i am setting the "Custom Date" value through workflow. The document works fine only @first occurence. What am trying to achieve is,

  1. First, I am setting the "Custom Date" value through the workflow.
  2. Retention Policy works, document successfully "Declare as Record".
  3. Next, i undeclare the document. Then starts the workflow.
  4. In the workflow, i removed the "Custom Date" value, proceed the approval of tasks.
  5. After successful approval, am setting the "Custom Date" again. But for now, the document not getting "Declare as Record".

Any help..!

0

If you can declare the documents as record manually? Make sure the document cannot be checked out.

Check if there is an event for declaring record via document compliance details dialog.

Whether all the actions in the same workflow? Try to add action to pause for 5 minutes after update the “Custom Date" value and check again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.