1

I have been trying to build the https://github.com/SharePoint/sp-dev-fx-webparts

I have gone through the instructions and reinstalled and installed but no luck I am now getting the error:

Cannot find module @microsoft/sp-build-web

Any ideas what I am doing wrong here. This happens after running - gulp build or gulp serve.

Thanks in Advance.

enter image description here

enter image description here

I get the above error when I run npm install @microsoft/sp-build-web.

Thanks in Advance.

2
  • Which version of nodeJS you have? and did npm install @microsoft/sp-build-web complete successfully or it gives any error?
    – Anil Pal
    Dec 11, 2019 at 6:27
  • Node V 10 and yes it gave some error as in my original post
    – naijacoder
    Dec 16, 2019 at 6:54

1 Answer 1

1

@microsoft/sp-build-web should be installed when you run npm install the first time.

In package.json, this is referenced in the devDependencies section:

"devDependencies": {
    "@microsoft/sp-build-web": "1.4.1",
    "@microsoft/sp-module-interfaces": "1.4.1",
    "@microsoft/sp-webpart-workbench": "1.4.1",
    "@types/chai": "3.4.34",
    "@types/mocha": "2.2.38",
    "@types/prop-types": "ts2.4",
    "ajv": "~5.2.2",
    "gulp": "~3.9.1",
    "webpack-bundle-analyzer": "^2.13.1"
}

As to why this was not installed in your case, there seems to be an issue with this particular sample.

Reference: Keep getting "Verification failed while extracting @microsoft/[email protected]".

To correct this, delete the file package-lock.json and run npm install again.

1
  • Getting there with some of the sample and thanks guys.I keep running npm as the error occurs and I go to package one sample. Also I think deleting the package-lock.json also did help alot
    – naijacoder
    Dec 16, 2019 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.