0

My Add-in challenges me for my credentials; even though I'm already authenticated by SharePoint. After 3 times, a blank page is displayed; even though my default.aspx is not a blank page. How can I fix this?

I am attempting to setup my VM so I can develop SharePoint Hosted Add-ins. I followed the tutorial below. Next I create a new solution in Visual Studio:

  1. Project Type: SharePoint Add-in (Visual C#)
  2. How do you want to host your SharePoint Add-in?: SharePoint-hosted
  3. What's the earliest version of SharePoint that you want your add-in to target?: SharePoint 2013
  4. Project is created
  5. Debug the Solution
  6. SharePoint asks if I want to trust the Add-in
  7. After accepting, I am challenged for my credentials
  8. After 3 attempts, a blank page is displayed

step 8, a blank page is displayed My Environment

  • Solution Name: addins__Cross_SC
  • SharePoint : 2013
  • Visual Studio: 2017
  • Windows : 2012 R2

Tutorial

| improve this question | | | | |
  • 1
    Did you configure your farm for add-ins? That is, did you create a domain for add-ins, configure your DNS, and setup the add-in service applications? – Rob Windsor Dec 5 '19 at 19:19
  • I registered a domain and prefix in PowerShell; the values are in Central Admin. I made it to the end of the instructions in the link below. I didn't see anything about setting up DNS. docs.microsoft.com/en-us/sharepoint/dev/sp-add-ins/… – amsackett Dec 6 '19 at 18:02
  • I have a bit of improvement; I can't reach my add-in from a browser on my Host but I can from my VM. I set DisableLoopbackCheck (link below). I've tried setting up a Forward Lookup in DNS but it isn't working. sharepointsolutiontips.blogspot.com/2016/07/… – amsackett Dec 6 '19 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.