1

The choice field adds a blank option in all my sharepoint lists. How do I remove this? the column settings does not have a blank option.

blank option in sharepoint list

choice settings

1

I can reproduce your issue in my SharePoint Online.

It seems the default behavior in modern list view now, there is a blank option in the choice column even we set the default value.

You can also check the thread:Spurious blank entry at top of a choice column entry

0

Try setting Default value of this column to open instead of None from column settings (shown in 2nd image).

Update:

Following below steps are working for me. Try below steps and check if it works for you:

  1. Go to List Settings.
  2. Navigate to Columns section and choose your choice column.
  3. At the end of the page, Set Default value of this column to open.
  4. Save.
  • 1
    tried it doesn't work. – Hussain Hameed Nov 29 at 3:30
  • Try by changing it from list settings. – Ganesh Sanap Nov 29 at 4:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.