4

I am working on a document library inside a modern team site collection, and i have added 5 managed metadata site columns to the document library.

Then using the "Column default value settings" i set the default values for the root folders. For example i have a root folder named "Main A", which have been linked to a managed metadata column named "Entity Type", as follow:-

enter image description here

Now this managed metadata values LLP will get applied to any sub-folder or document added inside the "Main A" root folder, which is fine. but the issue is that the "Main A" root folder itself will not get any value for the "Entity Type", as follow:-

enter image description here

so i can not do any filtering using the Entity Type when i am inside the root folders, since all the root folders in our case will have empty values for the managed metadata columns. so can anyone adivce on this please, How i can set default values to the root folders themselves, using the "Column default value settings" ? seems the UI will not allow us to do so, so can i use PnP script or any other approaches ?

1

Instead of directly creating a folder, you can try the below steps

  1. Ensure the default value for managed metadata column has been set

  2. Create a Content Type that inherits from folder content type

  3. Add the managed metadata column to this content type

  4. When creating the folder use the newly created content type instead of folder type, the default value should appear for the managed metadata column

  5. You can hide the folder option, by using the Edit New Menu option under New

|improve this answer|||||
0

when you use Column default value settings, you see all the fields available in your list, which you can define defaults for

on the right you have a column Used In, meaning that the default will be applied to that content type

folder, is itself a content type. if an item based on folder doesn't have the Entity Type field, then that field will not be available and therefore not visible or filterable

it seems you added the Entity Type as a list view field, and as a field for the document content type, but you're missing the folder content type.

defaults work just as well in folders but you just have to ensure that the field exists in the folders as well

one way is to create a new content type that inherits from folder and that contains Entity Type. then create new folders (which will be pre-filled with your default), or edit the existing folders properties to setup their field values (defaults are only applied on creation)

depending on what you're trying to accomplish, it may or may not make sense to have the field in both document and folder content types

another thing you'll have to keep in mind if you go down this path is the creation of folder-based items. it's very different from simply going to Files > New Folder, so you'll probably want to disable folder creation at the library level and train users to use New Document > [Folder] Content Type which is surprisingly difficult to find

anyway, hope this helps.

the other answer is pretty much related to this, I just felt like adding some extra details based on personal experience

|improve this answer|||||
0

Instead of using folders you can use Document Sets which will allow you to capture metadata and enable you to set column default value for items within the folder.

  1. Go to your site https://<site>/_layouts/15/ManageFeatures.aspx?Scope=Site and activate the feature "Document Sets".
  2. Navigate to your library settings > Advanced Settings > Allow Management of content types and set it to Yes
  3. Add Document Set content type to your library or create a new content type inheriting document set and customize to your need.
  4. You can now use either the shared column feature or column default values to set the default values.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.