0

We created normal workflow "Send email" using SharePoint 2013 workflow. But we are not receiving emails. We tried same with SharePoint 2010 workflow and its working. We also tried alerts me on the list and sharing site, everything working fine means we are receiving emails. Except SharePoint 2013 workflow emails sending to mailbox are coming. Start task process workflow also created and also all tasks has been completed successfully but email are not received.

We checked SMTP server, everything configured correctly. User Profile full sync was working fine and users are syncing from AD.

Note:We are suing SharePoint 2013 environment.

SP experts, Please suggest us.

  • Are you sending emails to external users (means email ids which do not have access on SharePoint)? – harshal gite Nov 9 at 17:48
  • No. Inside users only. – murali kuruva Nov 10 at 3:43
  • Is there any antivirus installed on the smtp server? please check it's logs. I have seen issues where antivirus blocks sending of emails. – harshal gite Nov 10 at 4:20
  • No issue with AntiVirus. Because alert emails we are receiving. Only issue workflow 2013 email notification. – murali kuruva Nov 10 at 9:50
0

Please check if "send mail" action does not work in both SharePoint workflow 2010 platform and SharePoint 2013 platform.

Please add the actions "log to history" before and after action "send mail" to check if the send mail action is performed.

And you can also add "pause for a duration" before the "send mail" action, see if it could help.

You may also check if there are some related ULS log.

And also try to hard code the email id rather picking from AD... and see the result.

Reference URL :

https://social.technet.microsoft.com/Forums/lync/en-US/3c76459c-01f5-4d75-be17-ee5b2ce1c1dd/sharepoint-designer-2013-workflow-not-sending-emails?forum=sharepointgeneral

  • Hi @Habibur, As i said its working for 2010 platform. but its not working for 2013. We tried above condtions and getting same error as "An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["1"],"SPClientServiceRequestDuration":["859"],"SPRequestGuid":[""],"request-id":[""],"X-FRAME-OPTIONS" Please suggest us. – murali kuruva Nov 10 at 4:02
  • Ooh ok... as we know SharePoint 2013 runs on different framework i. e. workflow manager... so can you please check from CA whether the workflow manager is showing as connected from manage service in the server page..... and also try to create sample notification workflow using sp 2013 workflow template... make sure in the wf template selection you are getting 2013 template. – Habibur Rahaman Nov 10 at 4:44
  • And also please check the web application where you are trying is connected with workflow manager proxy connection service.. go to WA setting then from the ribbon service connections – Habibur Rahaman Nov 10 at 4:55
  • Workflow Manager connected in CA. Tested sample Send email using 2013 workflow. Same issue we are getting. i am not getting second comment. please explore. Thank you.. – murali kuruva Nov 10 at 10:02
  • @Murali : My second command was about, if we go all web application page from CA.. then select the particular web application where you are running the wf... go to ribbon near general settings... click on proxy connection or something connection related I do not now remember the exact name... then one pop up window will be opened... there we can see what are the service connections are enabled for that wa... need to ensure here wf proxy connection is checked. – Habibur Rahaman Nov 10 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.