0

I am trying to publish the InfoPath 2013 form on SharePoint 2013 but it causing issues on last step "Cannot update library or list". This form is already published on live have the same column and user have submitted more than 300 forms on live.

I updated some rules on form load and and section hide show rules. And trying to publish the form to live. It causing issues "Cannot update library or list" even I deleted some column and publish the form.

  1. I publish the same form on same site's sub-site is get uploaded there get working.
  2. IIS reset done.
  3. Restarted the system and InfoPath designer multiple time.
  4. ULS log returning:
    • SOAP exception: Microsoft.SharePoint.SPException: A duplicate field name "11851948-b05e-41be-9d9f-bc3bf55d1de3" was found
    • A duplicate field name "086f2b30-460c-4251-b75a-da88a5b205c1" was found.
  5. It looks on form publish it trying to recreate the column into the library.If I publish the form on new library then it get publish but not get publish on the existing library.This issues I am facing only for a single library.

Anyone have any idea, what is the exact cause in this?

  • Are you updating the exist Infopath form (xsn file)? Also please check the mapping of your fields and the columns in library. Maybe some match is broken. – Mark L Nov 6 at 7:18
  • @MarkL Yes I am trying to update the existing InfoPath form(xsn file). Mapping of fields and columns in library were get matching. Is there any other reasons for this issues? – Mobile Test Nov 6 at 8:58
  • How about last time publishing? By any chance you are publishing an old version xsn by mistake? – Mark L Nov 6 at 9:30
  • @MarkL Last time publish was working fine. But when I try to publish the xsn form after few minutes it starts causing the issue. – Mobile Test Nov 6 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.