0

SharePoint Online: Title Field not Showing in Searches

We've been having an issue where for certain documents the Title field would not display when searching, instead we were seeing the first line of the document. After a bit of Googling I have this:

https://blogs.msdn.microsoft.com/spses/2013/10/30/show-more-relevant-titles-in-search-results-in-sharepoint-2013-plus-some-other-improvements/

Reading which suggests that the issue is with the search schema having MetadataExtractorTitle at the top instead of Title. However, I changed this and while it worked for word documents it seems to have now broken PDFs (which were previously fine) these are now showing random bits of text some I'm not even sure where it's coming from as it can't be found when searching the document.

I've found that when I first upload a document to a library the Name field of the file is displayed untill I edit it to add the Title field which then causes it to change to the random text.

Currently the Mappings to crawled properties for Title are:

Mappings

but I have tried a few combinations, for some reason we have two of each Title and MetadataExtractorTitle Mappings, and nothing has worked besides the initial removal of MetadataExtractorTitle.

Does anyone have any experience with this who can assist?

0

After the change, please reindex the site and wait for 24 hours to check the result.

Similar issue posts for your reference:

https://social.technet.microsoft.com/Forums/office/en-US/c0c551af-e944-4f30-b538-1c40d461a76b/show-document-title-column-as-title-in-search-result-office-365?forum=sharepointsearch

https://www.sharepointagency.co.nz/consulting/blog-search/item/353-my-sharepoint-search-title-does-not-display-document-title.html

Take a look at the article about showing more relevant titles in search results in SharePoint 2013 plus some other improvements:

https://blogs.msdn.microsoft.com/spses/2013/10/30/show-more-relevant-titles-in-search-results-in-sharepoint-2013-plus-some-other-improvements/

  • I did do this originally and it went from word documents not showing titles and pdfs being fine to Word documents being fine and now pdfs aren't showing titles. For some reason why have two Title mappings in our crawled properties. I'm not sure if one is wrong somehow. – Lewkir Nov 12 '19 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.