0

I created a new basic webpart, and deployed it into the SharePoint online app catalog. After that, I tried to add it to the site contents of one SharePoint site. But webpart is not visible under "From your organization" and "apps you can add". Please help me with this.

Thanks, Sravan

0

After testing your webpart in the workbench, you can deploy the webpart by following the next steps:

  1. In the console window, go to the web part project directory created
  2. In the console window, enter the following command to package the web part: gulp package-solution
  3. Go to your appcatalog (usually at https://tenantName.sharepoint.com/sites/AppCatalog
  4. Drag and drop the package you just created
  5. SharePoint displays a dialog and asks you to trust the packages, click on "DEPLOY"
  6. Go to your site collection and click on the gear to select "Add an app"
  7. In the search box type the name of your app and press enter
  8. Select your app from the list and install it on the site
  9. Go to a modern page, edit it and add your new webpart as needed

You cand find these steps and much more on the Microsoft tutorial for creating your first webpart (SPFx) https://docs.microsoft.com/en-us/sharepoint/dev/spfx/web-parts/get-started/build-a-hello-world-web-part

  • Hi Gonzix, Thanks for your reply. I followed the same steps as you mentioned, but in the 7th step, I can't find my app. – Sravan Nov 5 '19 at 6:57
  • Could you share your app manifest? – Gonzix Nov 5 '19 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.