0

Looking for a way to add existing newly created column called Business Area which is a choice based column to add a document form in SharePoint Online.

This form appear when I try uploading a document in there.

It would be of great help if there is a solution for this at the earliest.

For Example:

I am not able to see a column in the below image which I recently created into one of my list.

enter image description here

enter image description here

enter image description here

enter image description here

10
  • Are you able to see this column in list/library settings? Are there multiple content types or anything added on your list/library?? – Ganesh Sanap Nov 4 '19 at 9:46
  • Is this SharePoint OOTB form or customized/InfoPath form?? – Ganesh Sanap Nov 4 '19 at 9:47
  • @GaneshSanap Yes I am able to see the column in the List/ Library - There is a content type. Thank you – Tejas Thite Nov 4 '19 at 9:54
  • @GaneshSanap not sure if the is created using OOTB – Tejas Thite Nov 4 '19 at 9:54
  • You need to add this column to the content type (for which you have opened form). – Ganesh Sanap Nov 4 '19 at 10:04
0

That particular column need to be added in the content type. Go to site setting page - > Site column and content type section > click on content type >find your content type from this page >then click on add column from existing site column, here you can add your column to the content type.

0

Tejas, I assume you want to add a column to a specific content type. Here is a tutorial about how to do this in classic experience. It is a bit different in UI in modern experience, but the process is still the same.

0

This has been Sorted - The issue was with having the content type set as readonly, Which was changed to be modified which has fixed the issue

0

Click on "Document" under Content Types. There will be an option to Add from existing site or list columns. Click on it and select "Business Area" and click add.

enter image description here

Now check if your form has the "Business Area" field on it.

If Content-type is marked read-only, then you can go in "Advanced Settings" of the content type and change it from read-only.

10
  • Tried this i dont see the option to "Add from existing site or List column" – Tejas Thite Nov 5 '19 at 6:26
  • You need minimum "Design" permissions at site level to modify content types – harshal gite Nov 5 '19 at 6:37
  • I have full control for the Library and i am also a site collections Administrator – Tejas Thite Nov 5 '19 at 6:40
  • As a work around, you can create the column again (if no data) and then while creating, there is an option to "add to all content types". you can check this and then create the column – harshal gite Nov 5 '19 at 6:42
  • BTW it is weird for you not to see all settings in the content type being a Site Collection Admin. – harshal gite Nov 5 '19 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.