0

I have this error on each server of SharePoint Farm(APP, WFE, Search).

Full message:

Insufficient SQL database permissions for user 'Name: NT AUTHORITY\SYSTEM SID: S-1-5-18 ImpersonationLevel: None' in database SP Config DB on SQL Server instance 'XXX'. Additional error information from SQL Server is included below.

The EXECUTE permission was denied on the object 'proc_getObject', database 'SP Config DB', schema 'dbo'

I don't think that it is a duplicate because the following steps weren't helpful.

Expand your SharePoint Configuration database 'SharePoint_Config' and navigate to ‘proc_getObject’ under Programmability ->Stored Procedures Right-click proc_proc_getObject and choose Properties Click on Permission on the left launch Select the Search button and browse for ‘WSS_Content_Application_Pools’ Provide ‘Execute’ permissions for ‘WSS_Content_Application_Pools’ Click OK

NT AUTHORITY\SYSTEM SID: S-1-5-18 is the LOCAL SYSTEM account.

SPDataAccess and WSS_Content_Applications_Pools db roles have Execute(dbo) permissions to this stored procedure.

Any ideas?

Update

It triggered by task scheduler job "Desired State Configuration - > Consistency"

  • do you by any chance use the SCOM monitoring for Sharepoint with standard sharepoint pack? – Marek Sarad Nov 4 at 17:27
  • Not. We don't use SCOM. There aren't any SCOM agents installed on servers. – Raf Nov 5 at 5:36
  • ok I have seen that error when the agent wasn't correctly configured and was connecting to SQL with /System credential – Marek Sarad Nov 5 at 8:45
  • May it be comes from the latest CU? October 2019 – Raf Nov 5 at 13:22
0

I was curious to know how PowerShell.exe or PowerShell_ISE.exe processes are linked to Category of Upgrade in ULS log. Because, in our SharePoint 2013 on-prem farm, all databases' Upgrade Statuses are showing No action required. So, it doesn't make sense to me that it is related to any upgrade or SharePoint patching.

What I have found out is (I was not aware before) that launching "SharePoint 2013 Management Shell" or Window PowerShell ISE and then adding Microsoft.SharePoint.PowerShell PSSnapin creates ULS log items of Upgrade category, which might be confusing. Also, noticeable is that a connection to SharePoint Configuration database is also made, as can be seen in the log with the same correlation id.

Having said that, in your case, you may need to find out what process (or manually?) starts/launches the PowerShell process. Is the error being repeated with a specific time interval? If it does repeat at the same time every day then it would be worth to compare SharePoint TimerJobs' LastRunTime with the ULS logs' timestamps to figure out what job is involved, if any.

  • Matiur Rahman Thank you for your answer. This error appeared each 15 minutes. I tried to find which timerjob is involved but without success. I tried to manually run each timerjob that configured to fire each 15 minutes and there are no errors in logs. – Raf Nov 6 at 4:29
  • Any other task scheduler job outside SharePoint executing PowerShell script? Also, do you see these errors in the event viewer? – Matiur Rahman Nov 6 at 14:43
  • Yes. It is affected by task scheduler job "Desired State Configuration - > Consistency". Errors registered in SP Logs and Event Logs. Can I disable this job? – Raf Nov 7 at 4:32
  • I'm not sure about that job. But I don't think it's required by SharePoint as I don't see it in our on-prem SP 2013 environment – Matiur Rahman Nov 7 at 19:02
0

I figured out that it is triggered by Microsoft planning task - "Desired State Configuration - > Consistency".

Action: -NonInt -Window Hidden -Command "Invoke-CimMethod -Namespace root/Microsoft/Windows/DesiredStateConfiguration -Cl MSFT_DSCLocalConfigurationManager -Method PerformRequiredConfigurationChecks -Arguments @{Flags = [System.UInt32]1}"

Than i run PS command Get-DscConfiguration and find out that "Snow Inventory Agent" is involved.

enter image description here

Workaround: Configure "Desired State Configuration - > Consistency" job to run under SP Farm account(local admin + dbOwner).

If you know more elegant way, please suggest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.