0

I'm experiencing a problem where whenever I export an excel sheet to SharePoint Online (List) through the export function in excel, the "Customize Forms" option wont appear under powerapps. Whenever I make a custom list within Sharepoint Online it does show up.

I tried creating a form through the form options which takes me to the powerapps environment but whenever I publish it, it is still not recognized as a custom form for "Add item".

Does anyone know a solution to this problem? I would love to know since I am exporting alot of data I cannot paste the data in quick edit.

Cheers!

Exported list from excel

Sharepoint Online created list

  • Have you tried creating a standard view to replace the default datasheet view that gets created when you exported the excel table to SharePoint? – Donspeck Nov 1 '19 at 21:47
  • Try creating List template with data and create another list with this template and check if this option is available now ? – Ravi Nov 2 '19 at 3:54
  • @Donspeck Hey clever option to try. Unfortuneately it didn't work. Customize forms still won't show. – Richyrich Nov 4 '19 at 8:33
  • @Ravi I tried to create a list template, according to the microsoft sharepoint support page it is supposed to be under "Permissions and management". But I did not find this option within my list settings. Is it possible that it is a hidden function? – Richyrich Nov 4 '19 at 8:35
  • Looks like Microsoft has fixed this issue. I can no longer reproduce this problem. – Donspeck Dec 7 '19 at 6:47
0

I can reproduce your issue. It seems that PowerApps cannot customize the list export from excel client.

Try to use SharePoint default "Import Spreadsheet" template to import excel data to SharePoint list.

| improve this answer | |
  • Thanks I had some issues using the Import spreadsheet due to plugin incompability issues in internet explorer. I used an colleagues (older notebook) to load the data with the import spreadsheet option. Can edit forms perfectly now. Hope you have a nice day! – Richyrich Nov 5 '19 at 10:20
0

I'm having the same issue. But with a sharepoint list that was transfered from sharepoint 2013 to the online version...

The list is ok, but the "custumize form" option doesn't appear.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.