0

I have a simple web-part Hello Word from the tutorial of "Build your first web part" from Microsoft. However, every time I upload web part, the column "Deployed" is checked to "No", but column "Tenant Deployed" is checked "Yes".

This is the error I'm having

Deployment failed.  
Correlation ID: 8f42129f-b0c5-a000-40fb-3b7377e8541d

This is my package-Solution.json

{
  "$schema": "https://developer.microsoft.com/json-schemas/spfx-build/package-solution.schema.json",
  "solution": {
    "name": "test-1-client-side-solution",
    "id": "00d7fc42-2ae8-451c-a23f-42142d53cae4",
    "version": "1.0.0.0",
    "includeClientSideAssets": true,
    "skipFeatureDeployment": true
  },
  "paths": {
    "zippedPackage": "solution/test-1.sppkg"
  }
}

I also tried the following commands.

gulp clean
gulp bundle
gulp bundle--ship
gulp package-solution --ship
  • Which version of SharePoint are you using? – harshal gite Nov 3 '19 at 15:37
  • @harshalgite here: ` vti_encoding:SR|utf8-nl vti_extenderversion:SR|16.0.0.19423 ` – Saul Kevin Silva Nov 4 '19 at 10:08
  • SharePoint 2016? – harshal gite Nov 4 '19 at 10:41
  • yes, it's Sharepoint online 2016 – Saul Kevin Silva Nov 4 '19 at 10:56
0

No need to run "gulp bundle" command. Execute below commands:

gulp clean
gulp bundle --ship
gulp package-solution --ship

If the answer is helpful, please upvote and mark as accepted.

  • After doing the commands above. My App package error message "Deployment failed. Correlation ID: 4145129f-a0b2-a000-d85a-d016b768719d" – Saul Kevin Silva Oct 28 '19 at 11:38
  • Did you check the webpart in your local workbench? – Md. Nizam Uddin Mahmud Oct 28 '19 at 11:55
  • Yes, it works like the Microsoft example and the terminal doesn't show any errors. – Saul Kevin Silva Oct 28 '19 at 11:58
  • I always execute commands which I provided and it works perfectly. Do you have the "Contribute" permission for the "AppCatalog" site? – Md. Nizam Uddin Mahmud Oct 28 '19 at 12:09
  • I'm a catalog Owner with full control permission. Is there any other solution to get the logs of the errors? – Saul Kevin Silva Oct 28 '19 at 12:16
0

Delete the app from app catalogue and wait for 20-30minutes and then try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.