The Search box in SharePoint 2013 custom list is not working all of the sudden. I'm unable to find items by ID as I used to do before. I have tried to run increment crawl, full crawl, re indexing the list and site but still not working. Hoping someone can help me troubleshoot this issue.


  • I can verify that the CRAWL has been performed on the list items from the crawl log.
  • set “Require content approval for submitted item?” to “No”.
  • the site and the sharepoint list are allowed to search
  • nothing useful in the ULS detailed log
  • issue happened after installing updates, but no upgrades has been done on the farm.
  • are you getting any error? Oct 14, 2019 at 11:26
  • @harshalgite no error when searching just an empty page.
    – Elssss
    Oct 14, 2019 at 11:27
  • Any errors in Crawl Log? was the full crawl complete? Is it working on any other list/library? Oct 14, 2019 at 11:27
  • @harshalgite its not working on other lists/libraries. Crawl was complete, there were errors but when trying to parse some PDF file.
    – Elssss
    Oct 14, 2019 at 11:34
  • If the issue has occurred after installing updates you can open a free support ticket with MS. Oct 14, 2019 at 12:05

3 Answers 3


Try any of the below steps:

  • Try rebooting the server
  • Try restarting the services and service application
  • Check account associated with the service application if it is working
  • Try resetting the index using index reset. Check this article.
  • If nothing works, then I think you should run the config wizard (check for possibilities if it breaks something and only then try this)

When you install SharePoint updates, you have to run the config wizard after, or the farm will not be in a supported state. If you call MSFT this is one of the first things that they will have you do.


The ListItemID property in the search service is considered "Queryable" but not "Searchable" meaning that search won’t look at list item IDs unless you explicitly tell it to.

In other words:

  • A search for “4832” will bring back files and items that have 4832 in their bodies or in searchable text fields.
  • A search for “ListItemId:4832” will bring back items that have that ID number.

Searching for items by just plugging their ID number into the search box is not necessarily going to return them.

There are a few possible workarounds, including:

  • Train people to search with the prefix "ListItemID:" when using the list-level search box.
  • Create a custom page for searching and displaying search results from the list in question.
  • Set up a query rule that fires off when search text contains only numbers, and display a promoted result block of items where the ListItemID matches the query. This requires people to use the site-level search, not the list-level search.
  • Tried that but it doesn't work either.
    – Elssss
    Oct 16, 2019 at 4:44
  • I'm sorry, what did you try? Searching "ListItemId:x" isn't giving the expected result?
    – Thriggle
    Oct 17, 2019 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.