1

We're using a SP 2019 "Small Non-High Availability Min Role farm".

App Server: Application with Search FE Server: Front End with Distributed Cache

Hardware specs:

SharePoint Version FE + APP: 16.0.10350.20000 OS System FE + APP: Windows Server 2019 Data center 1809 – OS Build: 17763.678 Hardware: 4 core CPU + 24 GB RAM

Hardware specs SQL:

SQL Version: SQL Server 2017 14.0.1000.169 OS System SQL: Windows Server 2019 Data center 1809 – OS Build: 17763.678 Hardware: 4 Core CPU + 16 GB RAM

In general the system is running, all services are up and working. There are no errors shown within our Search Application Topology. Incremental Crawls are running and added content is listed within the index. There are no errors within the crawl logs.

However. If we try to use the search we're always getting errors with Correlation ID's. Error on results page

I tried to include the ULS Logs, but they were counted as spam.

We've tried the following steps to solve the issue:

  • Index Reset
  • recreate Search Service Application
  • Search account switched
  • Configuration Cache deleted + Index reset
  • new installation of the farm

None of them helped with our issue. We think that there is something between the SharePoint servers preventing the results to show up. A single server farm test was running without these issue.

Maybe someone can help us?

1

I can confirm what you see, that this is a bug somewhere.

It appears to me that SharePoint is relying on the port already being open in the firewall. There is a non-sharepoint pre-defined rule called "Windows Communication Foundation Net.TCP Listener Adapter (TCP-In)" which allows port 808. However, they tie this to the EXE "%systemroot%\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\SMSvcHost.exe"

It looks like the location of the EXE changed (possibly in Server 2019?). Task manager actually shows it located at "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SMSvcHost.exe", which would explain why the rule isn't hitting.

To work around this, I create a rule called WCF, that allowed port 808 for any application. Search began working immediately after that.

1
  • I had SharePoint 2019 Farm and getting same error message, after allowing 808 port (inbound and outbound) it started working. thanks a lot........ Jul 5 '21 at 13:08
0

Based on the error message, it appears to be issue with service application proxy association. Validate once in web application where you are performing search on whether search service application is enabled under Central admin->Application Management->Configure Service application associations. If it is already enabled then toggle it like disable and re-enable it. If search is indexing the items and you can see some number of items indexed then this is not the issue with search service application.

2
  • Unfortunately disabling and re-enabling of the search service application proxy association didn't resolve the issue.
    – AMeingast
    Oct 9 '19 at 12:00
  • What error message do you see in ULS logs? How about create new test web application and check with that to see whether it works or not? Oct 10 '19 at 5:32
0

We were able to find the error in this case. The port 808 TCP was blocked on the application server within the Windows Server 2019 firewall. This port handles the Search - Query processing component communication.

We're still in contact with the Microsoft support to find out if it's a bug within the installation process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.