0
  • SharePoint 2016 MinRole Farm with latest patch KB4475590 (September/2019) Security update for SharePoint Enterprise Server 2016 Core.
  • Scheduled incremental crawls are not running even though in Central Administration the Next Incremental crawl date and time gets updated in the Manage Content Sources view, but nothing really happens.
  • If I manually trigger an incremental crawl to run it works fine.
  • No errors are being logged in ULS Logs or in event viewer.
  • Indexing Schedule Manager Timer Job on the Search Server is not running, even when I click on Run Now, it doesn't seem to work.
  • In Central Administration>Server in Farm, the server with Role Application with Search is showing Compliant: No (Fix) and I've clicked on the Fix link and after it runs for a while, the Compliant status doesn't change to Yes.

Things I've tried to troubleshoot the issue with no success:

  • Stop search services on the server and Timer service, clearing config cache and restarting all services.

  • index reset, run full crawl after that manually and set up the scheduled incremental crawl, which will not run neither.

  • created a new Content Source and set up the incremental crawls to see if it will run in this new content source and that didn't happen neither.

Any idea or suggestions about what the issue is and how to fix it?

  • Which service is showing as non-complaint under 'Application with Search' role? – Goldi Agrawal Oct 8 at 6:31
  • @GoldiAgrawal what is showing not compliant is the Server with MinRole 'Application with Search', not a service. – MLC Oct 9 at 14:14
  • Yes the server will show as non-complaint because it is either running the service which it is not supposed to run or not running the service, it is supposed to run.. That is the whole meaning Minrole... Could you validate in Central admin->System Settings->Manage Services in Server to see if in-front of any service, it shows as Fix option. – Goldi Agrawal Oct 10 at 5:34
1

Try running this one liner in PowerShell.

(get-spenterprisesearchserviceinstance).synchronize()

From here: https://blogs.technet.microsoft.com/victorbutuza/2009/08/26/crawl-schedules-do-not-work/

The powershell does the same as the code solution that the article provides.

  • I ran the command and it didn't make the scheduled incremental crawls to get triggered. – MLC Oct 9 at 15:40
0

Rebooting this server resolved the issue and Timer Job 'Indexing schedule manager on AppServer' started running as scheduled by default every 5 minutes and also the scheduled crawls starting working again.

Before rebooting:

    Get-SPTimerJob -Identity 'Indexing schedule manager on AppServer'| Format-Table DisplayName,Id,LastRunTime,Status

DisplayName                              Id         LastRunTime          Status
-----------                              --         -----------          ------
Indexing Schedule Manager on AppServer XXXXXX       1/1/0001 12:00:00 AM Online

After Rebooting:

Get-SPTimerJob -Identity 'Indexing schedule manager on AppServer'| Format-Table DisplayName,Id,LastRunTime,Status

    DisplayName                              Id         LastRunTime          Status
    -----------                              --         -----------          ------
    Indexing Schedule Manager on AppServer XXXXXX       10/9/2019 3:05:45 PM Online

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.