0

On item create, the workflow goes into suspended mode with the following information:

RequestorId: e55d1c73-4536-5312-0000-000000000000.
Details: An unhandled exception occurred during the execution of the workflow instance.
Exception details: System.IO.InvalidDataException: Unable to deserialize HTTP response content. Expected ContentType : 'application/json', 'text/plain' or 'text/html', Received ContentType : 'text/html'. Content (truncated) : ''. ResponseStatusCode : 'OK' Request Uri : 'http://xxxxxxxxxxx.com/sites/increport/_api/web/lists(guid'bc9db790-45a6-4bf5-83c9-427abdf46e30')' at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

  • Thanks Waqas, however I do not have any HTTP calls in the workflow. It's just a simple workflow to log a comment to the workflow history. – Jakim Oct 7 at 12:50
  • One thing to check is that if the user starting the workflow has a profile in the UPS, 2013 workflow requires this. – Josh McClanahan Oct 7 at 23:46
0

Don’t have a simple solution, but been down the road of troubleshooting SP 2013 workflows so often I can’t resist tossing in my two cents. If this is a case where you’re just writing plain text to the history list and that fails, I wouldn’t focus too much on the failure message text, but would first determine whether Workflow 2013 service is working at all in the farm, whether User Profile Service is accessible, whether user running the workflow has a user profile, and whether user running can write to the history list and subject list. I’d try something possibly even simpler than a history list write and just update title column in the subject list.

After several years of dealing with SP 2013 workflows in a few farms, I recommend using the 2010 workflow engine whenever possible. Especially in a well-hardened secure environment, it’s painful to keep it going and to troubleshoot. Maybe this has something to do with why it’s still version 1 after the early hype, and why MS is abandoning it for Flow.

0

The solution was to uninstall and re-install Workflow Manager, then run the timer job "Refresh Trusted Security Token Services Metadata feed" because there was an authentication error after the installation of workflow manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.