0

I have an existing workflow in SharePoint Online that uses a drop-down list on the initiation form. In the past I have been able to modify the available choices with no problem, but currently if I add/remove/change one of the choices in the Initiation form parameters box and then re-publish the workflow, it does not show the changes on the WFInitForm when running the workflow.

Publishing appears to be successful as far as I can tell but if I close SPD and then re-open it, the Initiation form parameters have reverted back to the original values.

If I delete the WFInitForm.aspx file and re-publish, a new file is created but it keeps the original values. I've also tried adding a new field to the form but get the same result.

I've also been able to reproduce the issue on a different site collection with a brand new workflow.

Has anyone else experienced this or have any suggestions for me to try before contacting Microsoft?

  • I have logged a support ticket with Microsoft and will update here when I have more information. – user79408 Oct 2 at 21:42
1

We noticed exactly the same behavior...we are searching and testing for some days trying to understand what happens.

I just reproduced a very simple problem so that I could rise a support ticket on Office 365. Just create a team classic site, add a new workflow with one initiation parameter using SPD, publish the Workflow, reopen the workflow to add a second initiation parameter, republish the workflow and if you reopen again the workflow, the second parameter is no more there...but this parameter appears in the local variables !!!

We could reproduce the problem on two different tenants, using SPD on three different machines and with different site installed from different templates…

The conclusion seems to be the same: it is impossible to change anything in the initiation parameters of an existing workflow using SPD…

Regards.

0

Per my test, the issue only exists in SharePoint 2013 platform workflow.

You can create SharePoint 2010 platform workflow.

0

After a week of troubleshooting with Microsoft, the issue appears to be resolved but without any further explanation than "updates are happening constantly and it's now working".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.