We have some users reported they cannot upload files to a document library. They are using Chrome and drag/drop some files. Total file size is less than 1MB.

After drag the files to the document library, an error shows up like:

Sorry, your files couldn't be uploaded. The upload might be too large or the server might be experiencing high network traffic.

We are using SP2016 on-premise. The ULS logs are:

Exception occured in scope Microsoft.SharePoint.SPFile._SerializeToJson. Exception=System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

SocialRESTExceptionProcessingHandler.DoServerExceptionProcessing - SharePoint Server Exception [System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002) Unknown SPRequest error occurred. More information: 0x80070002

After further test, we found the error is most likely occur when it is the first file user upload. If the same user upload another time for the same file, it success (some users need to try 3rd or 4th time).

Also, error only occur if user upload file by "Drag & Drop".

User tried to troubleshoot with F12 tool and get Status Code: 413 Request Entity Too Large. I found 413 is a FAQ but all solution I found is for custom JSON or WCF solution. Our problem is occurring on OOTB library. The only different is we have setup reverse proxy server between WFE server and the Internet users. The delay (maybe around 1sec) may trigger the error randomly. Also when they upload file in this way, the upload progress bar will keep shaking left and right (not always progressing, sometimes it is descending).

How can I further troubleshoot it and solve it?

  • 1
    It may not be related to SP. Try the uploads while monitoring the network traces. Commented Sep 26, 2019 at 8:45
  • We can reproduce the error and updated my question.
    – Mark L
    Commented Oct 8, 2019 at 13:14
  • Seems like a client browser issue. Can you reproduce the error in IE? If not, make sure Chrome browser is updated to the latest version. Commented Oct 9, 2019 at 5:17
  • Chrome is in latest version already.
    – Mark L
    Commented Oct 9, 2019 at 6:52
  • @MarkL Use network traffic tools such as fiddler to confirm that the actual request is not too large. When you get 413, do you see corresponding log entries in the ULS? If all fails, are there any means of attaching (remote) debugger? Commented Oct 9, 2019 at 7:37

1 Answer 1


this is not an answer but I am new here and cannot post a comment yet. I literally made this account to suggest trying the following. But it is not a solution so please be kind and don't downvote, just ask me to delete if that's what should be done.

Assuming you've tried this in other browsers (like FireFox/Edge/IE) to isolate that this is indeed a Chrome-only issue: In chrome, you could try turning off "Use hardware acceleration when available" and see if issue persists? @ chrome://settings/system > then just flip the switch and restart chrome & try again.

Might be worth a quick peek since you stated this error only occurs with drag & drop, and only in Chrome.

Good luck, and again let me know if this should be deleted. Thank you!

  • Thanks for your suggestion. I tried chrome with hardware acceleration and still able to get the error.
    – Mark L
    Commented Oct 10, 2019 at 16:43
  • You're welcome, I'm sorry that didn't offer any clues. Best of luck with this. Commented Oct 10, 2019 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.