1

I need a WF that sends emails when docs are uploaded and I have used a 2010 template with impersonation step. I might need now to use a function that is only in the 2013 template which does not have the impersonation step. What is the equivalent feature here?

1

The app step in SharePoint Designer Workflow 2013 is the equivalent of impersonation in 2010 workflows. If you aren't seeing this option available in SharePoint Designer, make sure you have the appropriate permissions. You need to enable "Workflows" feature in Site Features under Site Settings.

Check this article which shows how to enable it.

1
0

In SharePoint Designer 2013 workflows, you can use App Step which is equivalent to the Impersonation step in SharePoint Designer 2010 workflows.

Below official Microsoft documentation provides steps on how to create a workflow with elevated permissions by using the SharePoint Workflow platform:

Create a workflow with elevated permissions by using the SharePoint Workflow platform.

This article also covers how app step works in SharePoint context.

Note:

Before creating elevated permissions and using App Step in your workflow, I would suggest you to read my answer (also the comments) given in below link which covers some of the risks of using App Step.

Are there any risks if we enable our workflow 2013 to run on elevated privileges (to use app permissions)

0

The above answers are absolutely correct however let me add some details for you.

There are some loop holes that can put you in trouble especially the step where you grant permission to the app page.

The most important part is the XML that you use here.

Here you need to use /sitecollection/web in the Xml only if you are writing a workflow that exists on one of the sites inside the sitecollection.

<AppPermissionRequests AllowAppOnlyPolicy="true">
    <AppPermissionRequest Scope="http://sharepoint/content/sitecollection/web" Right="FullControl" />
</AppPermissionRequests>

If you are writing your designer workflow on the lists/libraries of the sitecollection itself do not use /sitecollection/web in the xml or else the elevation won't work. You need to use the below xml:

<AppPermissionRequests AllowAppOnlyPolicy="true">
    <AppPermissionRequest Scope="http://sharepoint/content/sitecollection/" Right="FullControl" />
</AppPermissionRequests>

For step by step instructions to be followed for configuring App step use the below mentioned URL -

Create a workflow with elevated permissions by using the SharePoint Workflow platform.

1
  • Fixed broken reference link. Sep 24 '19 at 3:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.