5

I have created a Site Template file (.stp). When I add it to the site templates gallery of the target farm it shows up in a strange tab when you go to provision the a new sub-site based on the template. I would like it to display in the publishing tab or a new custom tab (display category) on the create site page. The site template gallery doesn't allow you to assign the category.

My question is how does one configure which tab the template will show up in?

Here is a link to the .stp file.

enter image description here

3 Answers 3

4
+25

I can't say I've tried this myself, but I would expect this to work.

First, take a backup of your .stp-file. Rename the file from .stp to .cab. Find the Elements.xml-file that deploys the list template (probably there's only one Elements.xml here). In the Elements.xml file, change (or add if it doesn't exist) the "Group"-property (or perhaps DisplayCategory) of the list template element to the name of your wanted group. Finally, assemble the .cab file again (by using makecab, rename it back to .stp and finally add it to SharePoint again.

3
  • I cracked that open and it seems that the XML file in there (Manifest.xml) is very different from the site definition XML schema, and doesn't appear to have such an attribute.
    – James
    Jan 17, 2012 at 8:21
  • Would you mind sharing through e.g. pastebin.com and I might help?
    – tarjeieo
    Jan 17, 2012 at 8:24
  • I shared the file here : 4shared.com/file/79HZleZY/CommunityArea.html
    – James
    Jan 17, 2012 at 18:01
1

One option you have is to update the existing custom template tab name using the resource file in the 12 hive.

Modifying files in the 12 hive is sometimes not advised as they may break with updates etc., but this is an option nonetheless.

Under the "...\Web Server Extensions\12\Resources" folder, open the "core.en-us.resx" file (or the resource for the installed language).

Find the "TemplatePickerControl_Custom" value and replace it with the field you want.

You should see the following Xml:

<!-- TemplatePickerControl -->
<data name="TemplatePickerControl_Custom">
  <value>Custom</value>
</data>

Replace the contents of the value element with the name of your choice.

Make sure you do a full iisreset to see the change come into effect.

This is the default resource file, if you are using a language pack ShaerPoint may be picking up text from a different resource file.

7
  • This doesn't seem to work, is it under a different attribute?
    – James
    Jan 17, 2012 at 5:04
  • You need to do an iisreset to see the changes. Works here on my dev box.
    – Russell
    Jan 17, 2012 at 5:14
  • I did that, no difference the tab name is unaffected.
    – James
    Jan 17, 2012 at 5:43
  • I have updated my answer with some more details, hopefully this helps you get it working.
    – Russell
    Jan 17, 2012 at 5:56
  • That still doesn't work, i'm not using any special language pack, just stock MOSS 2K7.
    – James
    Jan 17, 2012 at 18:03
0

I never did figure this out. The solution I ended up going with was creating a custom site definition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.