0

while sharing permission and in all sorts of people picker i'm getting this error "Sorry, we're having trouble reaching the server" enter image description here on clicking Shared with i'm getting error "unexpected response data from server" enter image description here

i tried the following,

  • resetting IIS,
  • restarted the server
  • different user names
  • memory space is sufficinet

Please help me in fixing this error

0

Please try to Install and activate HTTP Activation as mentioned in below link.

Install and activate HTTP Activation

Also check that all the Application Pools are up and running.

if the issue still persist then kindly provide the ULS Logs.

  • thanks dhruvil29. ....HTTP is already activated , and with the ULS logs i found there is a issue with my user profile services, then checking furthur, i found that the port number which i used is restricted one, i've mentioned it in my answer, – Jegan Baskaran Sep 10 at 4:18
0

Thanks everyone who helped me.. i tried all your methods, unfortunately i couldn't fix my issue. Finally... i found the issue it is the Port number of the web application which is a restricted one and it doesn't allow the user profile service to fetch the names form the active directory, and after changing the correct port number the issue has been fixed.

Thanks again everyone..

0

There are a couple of reasons why you might be getting this issue . Please check all of these

  • Try IIS reset once from all front end servers.
  • Check Alternate Access Mappings settings for the web application.
  • Try deactivating "Limited-access user permission lockdown mode" Feature from site collection features
  • Make sure the domain account you are using for a SharePoint service account has the necessary permissions to read domain accounts, If you have one-way trust domain - Set the app password (stsadm -o setapppassword -password "Password") and follow the KB to add people picker domain https://support.microsoft.com/en-us/kb/2874332
  • Check if Anonymous Authentication is enabled for your web site in IIS.
  • Try updating "Query timeout" value from 25 to 60! (under: 15\TEMPLATE\LAYOUTS\clientpeoplepicker.js >> SPClientPeoplePicker.UserQueryMaxTimeout)
  • Try extending the web application to new port!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.