1

I am trying to enable external sharing in SharePoint online. It was already sharing with external people, I tried to troubleshoot few issues, so I turned it off, then I tried to turn it on again, but now I am getting this error message:

"You can’t set the sharing capability to the level you specified, because it is a less restrictive setting than either its parent site collection or your organization."

I am doing this by going to the SharePoint admin center, then policies and clicking on "Sharing". I drag the sliders to "New and existing guests", for both SharePoint and OneDrive, then when I click OK, it gives me this error. This only happened when I turned off the external sharing and turned it on again.

This happened to me on 2 different tenants, is there something wrong am doing or is it a bug?

Thanks.

2

I have done a test in my SharePoint online and I can reproduce your issue. This only happened when I turned off the external sharing and turned it on again from new SharePoint admin center.

enter image description here

i solved the issue by navigating to classic SharePoint admin center->Sharing->Choose "Allow users to invite and share with authenticated external users"->ok.

enter image description here

Then you can drag the sliders to "New and existing guests", for both SharePoint and OneDrive from new SharePoint admin center.

| improve this answer | |
  • Thanks @Lisa, I did so, it changed it for SharePoint. OneDrive sharing settings are still set to Least Permissive. – BR1 Sep 9 '19 at 19:37
  • Yes, OneDrive sharing settings will still set to Least Permissive, but you can drag the sliders to "New and existing guests" for OneDrive now. – Lisa Chen MSFT Sep 10 '19 at 9:27
  • thanks Lisa for your amazing help! – BR1 Sep 10 '19 at 9:43
0

You can change that in the Office 365 admin center.

  1. Go to https://admin.microsoft.com/
  2. Under Settings - Security & privacy
  3. Then Sharing, click Edit
  4. If not On, turn that on
  5. Click Site Settings (To change your external sharing settings for SharePoint, you need to go to Site Settings)
  6. On that side pane, change to the External Sharing level you want.

When you go back to SharePoint Admin Center you will be able to change that again.

| improve this answer | |
  • I am only a SharePoint admin, I don't have access to other settings in Office 365. So this option was not available when I clicked on Settings in the office 365 admin page. – BR1 Sep 9 '19 at 19:38
  • Will a global Admin be able to do that for you? – Murilo Santana Sep 9 '19 at 19:51
  • I don't know who's the admin, I only know the project manager, who requested this from the O365 team, and it's not easy communicating with them, I just solved it using what Lisa suggested. Thanks anyway @Murilo. – BR1 Sep 10 '19 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.