0

I'm working in a SharePoint 2013 on prem environment and I'm running into an odd issue. Here's the setup.

There is a subsite (A) in a site collection that has differing permissions from the parent. This subsite (A) has several subsites (B,C,D, etc) that inherit permissions from A.

Subsite A is managed by a group, Subsite A Owners. User X is a member of this group. There is another group in Subsite A called Group B. Group B is setup to allow access requests and those requests are sent to User X and the Group is owned by Subsite A Owners.

When User X goes into Group B to add users, the share with dialog box does not have the box to to input anyone's name. It is completely gone. The only thing that exists is the optional description box.

I have not seen this behavior before. Some things I've tried

  • Making sure User X has access to the Access Requests list/resetting the permissions inheritance
  • Disabling Limited Permission Lockdown Mode
  • Comparing various lists and settings to other sites via SPManager

We had tried giving User X site collection administrator permissions, but that didn't fix the issue. I'm not sure what else to do or check.

0

Try this: run Add-PnPUserToGroup as User X and see if it works. If it doesn't work then you have a permission misconfiguration somewhere and the error message should give you a clue. If the error message is generic you might be able to glean some context by Fiddling the traffic and inspecting the responses. Also the ULS logs might yield some clues (God, it's been years since I've gone ULS snooping. Cloud for the win!)

If the PowerShell command does work then you likely either have:

  • A platform bug
  • A client side customization that's preventing the rendering from working correctly
|improve this answer|||||
  • Is it possible to impersonate a user via the PnP Powershell module? – Eric Alexander Sep 5 '19 at 18:01
  • no, you're going to need to either replicate the issue with an account you control or have the user cooperate. – Derek Gusoff Sep 5 '19 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.