0

In SP2013, I am using left nav, and customizing it in the site settings navigation. What I want is that, when I click a link on the nav, when I go to the page, the link in the nav will be bold. But I am getting inconsistent behavior. It either always bolds the last link or not bold any link.

Some of the links go to the same file, but it has different url params in the end of the url, if that matters.

Does anyone know?

Thanks

  • What are your options for customization? Can you include JS/jQuery in master page? – Slaven Semper Sep 5 at 9:43
  • try removing all links and adding them again. – harshal gite Sep 5 at 11:03
  • There is no js/jquery. I meant customization in that I used the GUI in the navigation in site settings, to add links. – omega Sep 5 at 13:05
0

This is by design.

By default, links in quick launch does not accept query string parameters. when applying the 'selected' style it matches only the url component without parameters.

So all your links will be defaulted to "/Lists/Management/NewForm.aspx" when applying the style and last navigation item will be selected.

As a workaround you can put a script in your masterpage to remove current "selected" style and apply a new style by matching current url and quicklaunch url.

Similar issue post for your reference:

Quick Launch selected item (which get bold font weight) is being wrongly determined

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.