0

I've been researching on the web for quite some time now, and while others have reported the similar error message *"A Microsoft SharePoint Server State Service error occurred while processing your request. For more information, contact your server farm administrator.

Click Start over to load a new copy of the form. If this error persists, contact the support team for the Web site.Click Close to exit this message."*

The solutions seem to be that there is a look up choice field or a data connection that has gone awry. This form was working fine until a day or so ago, and there are no data connections - only the one for the submit (which is correct - I've checked it) and the choices data field which is built into the form - it doesn't go anywhere to get the choices they are manually added to the field itself.

The thing is, once you fill in the form and hit submit, it will "sending data to the server" for the prescribed time out period, then 'fail' with the message above - however the data is submitted to the library and the workflows fire as normal.

Correlation ID returns nothing except
Request URL: .../org/par/as/_layouts/15/Postback.FormServer.aspx and when I network trace, it's giving me a 401 / Unauthorized... but it's been working before and none of the logs I can find make mention of which account is unauthorized. I've checked the WFE and the SQL.. nada.

The only server changes I know of are a WFE reboot..

Was hoping for some ideas from the community before I rebuild...

thanks!

0

Check the following points to troubleshoot your issue:

  1. Go to Central Administration –> Manage Service Applications and make sure the State Service is running.

  2. Check if you have enough space on the drive on which SQL Server is running.

  3. Set the state service database to SIMPLE recovery mode. Make sure the transaction log for State Service database have enough space.

  4. Disable the authentication loopback check. Setting the DisableLoopbackCheck registry entry in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa registry subkey to 1. Then restart the server for this change to take effort.

  • Hi Hellofiona_MSFT! Thank you for your suggestions. Checked each step and all is as recommended in your notes - except for number 3. Our recovery mode is full as we have the SQL AlwaysOn High Availability mode enabled for all our SharePoint databases and as such, can't switch to simple recovery mode. – SPChick Sep 3 at 3:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.