0

There seem to be similar questions to this but none of those solutions worked.

I have a SharePoint list that inherits permissions from its parent. I have a test user who is part of the visitors group, having read access permissions.

The test user can access most of the other contenton the SharePoint site. But the test user cannot view the list, any of its views, or any of its items.

Access Denied. test.user@xxxxxxxx.onmicrosoft.com does not have permissions to access this resource.

If I change the user's permissions on the site to contribute then everything works properly, but I don't want them to have read-write access.

The master page being used by the site Seattle, and it is not checked out. I tried creating a standard view that contained only one field, the name (without edit link) and turned off individual item check-boxes. Still access denied.

The list has some calculated columns - not sure if that could be the cause.

I created a new list on the site with no fancy settings and it has the same problems.

Also, the list is configured so that everyone can see draft versions.

0

Check what is checked off for the permission levels for the Read users.

Perhaps viewing and reading from list got unchecked.

Go the Site Settings --> Site Permissions --> Permissions Levels -->Read.

Make sure the List Permissions are set as you want them to be.

By default, View Items, Open Items, View Versions, Create Alerts and View Application Pages should be checked.

  • 1
    Dude. No need to change the answers to make them all yours @Sanap. You did not even give me 2 seconds to go back and fix my errors. Try waiting longer than 2 seconds before editing a post. – lazoDev Aug 20 at 14:00
  • Confirmed those settings are all still default – Greg Viers Aug 20 at 14:01
  • Have you tried putting the user at the top directly then adding them to the Read group directly on the list? Could be a permissions heirarchy issue at the top level. Do you use an All Users group from AD or are users added individually into your groups? – lazoDev Aug 20 at 14:07
  • I don't understand what you mean "top directly". The user is a part of the visitors group, and the test user has been added individually to it – Greg Viers Aug 20 at 14:19
  • At the top level of your permissions on the site collection. Make sure they are there with Read permissions and try placing them directly into the list with read permissions to test if that worked for the user. If not, it might be something wrong with their AD account. Is it all users or just one? – lazoDev Aug 20 at 15:06
0

Check if other users have this issue. If this issue just happens on a single user, you can try to remove the user from the site, then grant permission again.

Double-confirm if the list has unique permissions. If yes,disable "Limited-access user permission lockdown mode" at site collection level, then test again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.