I am running a SharePoint 2010 enterprise server. A few months ago I had working InfoPath integration however we weren't sure we'd have the CALS to go live with it so I disabled the Enterprise Site Features for consistancy across environments.

The situation has changed and I've re-enabled the Enterprise Site Features. However, when trying to create a new form for a SharePoint list in InfoPath 2010, I get the message "This feature requires SharePoint Server 2010 or greater with InfoPath Services enabled" from the new form wizard. This happens when the wizard tries to connect to any site in the site collection.

I have completed these steps (including removing & re-adding the service with the '-force' parameter) - http://technet.microsoft.com/en-us/library/ff621101.aspx - and tried re-enabling the feature with no luck. I've also tried via stadm as mentioned here: http://www.sharepointassist.com/2010/06/15/wheres-infopath-forms-services-in-sharepoint-2010/

I'd love some pointers on what to try next!


  • I am facing the same problem. As the scenario is different. As Our server where SharePoint is installed is in USA and I have no access on server and we are provided with sharePoint site link and when I try to use the same link in infopath, I am getting is error. So, If I manage to enable this feature, will I be able to access the SP site from Infopath? Thanks.
    – Ginni
    Feb 6, 2013 at 7:52

2 Answers 2


Did you also activate the "SharePoint Server Enterprise Site Collection" features?

  • Thanks for the reply - yes, that is set as active for the site collection. I don't think I've tried disabling/re-enabling that though so I'll try that now!
    – Beeblebrox
    Jan 12, 2012 at 22:03
  • Unfortutunately disabling/re-enabling the feature did not help.
    – Beeblebrox
    Jan 12, 2012 at 22:33
  • While this post may answer the question, we prefer more details such as "why". Please consider editing your post with additional details. See How to Answer for general guidelines.
    – Kit Menke
    Jan 13, 2012 at 14:28
  • My mistake, I thought the +1 was more of a 'thanks' and used for a related step and that actually marking it as an answer was reserved for those that solved the problem. Will remember that in future.
    – Beeblebrox
    Jan 15, 2012 at 23:34

I found the fix;

This was a useful site which pointed me in the right direction: http://blogs.breeze.net/mickb/2010/10/25/SharePoint2010InfoPathFormsServicesIsNotTurnedOn.aspx

Under the Upgrade and Migration config site section (next to where you add the enterprise key) there's an 'Enable Features on Existing Sites' ($site/_admin/enablefeatures.aspx). Running this process will re-enable the InfoPath service if it's been previously disabled (even if the InfoPath Service config settings say all should be fine & the service is running in the SharePoint manager).

Edit: just to clarify: all relevent site collection-level & site-level 'enable enterprise features' were already showing as enabled and present yet InfoPath still wouldn't connect. After running the above process, it does. All service & proxy settings remain as they were set before it was run.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.