0

It is so confusing that some parts of office fabric will not work as expected with different SPFx versions.

I have created a SPFx solution for SharePoint 2019 on-Premise. Following things are not working as expected so far:

  • Multi check box
  • Dialog styles

Can anyone tell me what are the supported versions of office fabric UI for each SPFx frameworks starting from 1.4.0.

  • Which version of SPFx you are using? – Ganesh Sanap Aug 14 '19 at 11:34
  • I have installed 1.8 in dev machine – Mihir Aug 14 '19 at 13:25
  • As I mentioned in my answer, SPFx 1.8 version supports Office fabric react 6.156.0. Try using it. – Ganesh Sanap Aug 14 '19 at 13:49
  • My target SP version is 2019 onprem. so 1.8 will not work – Mihir Aug 14 '19 at 16:30
  • Ok. For SP 2019, try using SPFx 1.4.1 – Ganesh Sanap Aug 14 '19 at 16:33
0

We recommend that you use the versions of the Office UI Fabric React package included in the project in the SharePoint Framework's Yeoman generator. For instance, the SharePoint Framework v1.7.0 release uses Fabric React v5.131.0

Note: Fabric React versions 2.x or older are not supported in SharePoint Framework.

Source: Office UI Fabric React.

Also, SPFx 1.8 supports Office fabric React 6.156.0.

Source: SPFx 1.8 now supports Office Fabric React 6.156.0.

There are some changes in usage of the Office UI Fabric icons in SPFx components as mentioned, here.

Also, you can check below Release notes of SPFx and Fabric React and check their typescript compatibility if that helps you.

References:

  1. SharePoint Framework Releases.
  2. Fabric React Demos.
  • What about SP 2016 / SPFx v 1.1? The Yeoman generator did not add any Fabric React dependencies into the scaffolded package, it only adds a dependency of Office UI Fabric Core v 1.4. – Dylan Cristy Nov 6 '19 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.