2

I am actually quite confused as to why it worked. Here are my steps:

  1. Make a web part of the library anywhere, change the toolbar to "show toolbar".
  2. Save.
  3. Edit the web part again, this time change the view to your default (All documents etc.).
  4. Save. It will disable the "show toolbar" style automatically.
  5. Edit the web part once again, change the toolbar back to "show toolbar".
  6. Save.

And now if you go back to the source of the document library it will have the show tool bar style applied (which lets you make new items based on your content types).

Problem is, I don't see any option in the settings to do this in a less janky way.

As you can see, it clearly is a document library and not a page.

enter image description here

1

I can reproduce your issue in my environment. It seems a default behavior.

Since "All documents" view and "Show Toolbar" have conflict, and it causes the Toolbar type changed in the source of library.

As a workaround, you can edit the source document library page and edit the web part to switch the Toolbar type to "Full Toolbar".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.